New to rhino and my snap to points doesn't work at all

THANKS for the input, you are so helpful. really appreciate it. have a great day. d

You might try One View…easier visualization.

thanks for the input. I think we will wait on that a bit. I may create a template with that layout and see how we like it complared to the standard. cheers, D

I wonder if he is working too far from the objects with a snap radius set way too big…

Hello, I looked and the snap to grid is set at .5mm don’t know what the other one is set to. They just don’t seem to work, the function that Helvetosaur sent me a video of is now working. We just can’t get the others to work. I will look in the program and try and find out what the distance is for them. I know that when I watch videos folks snaps seem to grab hold and sometimes I see videos where the name of the snap even shows up in writing, mine does none of that. So, we will see. cheers, d

Hello, I just turned on about all of them. I can get a square to now snap to a point on a circle but it is very very weak, I have to kind of know where the point is an slowly hover around and then it does it. But very weak, can one make it snap more strongly? cheers, d

Increase the snap radius.
DocumentProperties > Rhino Options > Modeling aids > Object snaps > Snap radius
Be aware that too large a snap radius can be a problem when working with geometry which has many details close together.

Hi - make sure that the Rhino Options > Modeling Aids > Cursor ToolTips > Osnap setting is checked.

Please turn off GridSnap until this problem is resolved. Make sure the ‘Grid Snap’ panel in the status bar at the bottom is not bold and blue…



Hello, thanks for the input on range, we just changed it to .5 from .25 maybe that will be of help to me. cheers, D

Hello, Just replied in the wrong place, thanks we just changed that to .5 mm cheers, D

Please turn off GridSnap altogether…

thanks, D

What did you change to .5 mm? Cursor snap radius is in screen pixels.

Probably Grid Snap Spacing…

Hi @cad.aurum,

Early on you mentioned that you are not new to CAD. I wonder if you have a concept of snapping that is based on a CAD program where snaps work differently to Rhino’s? If so, I think you will find it helpful to put that aside (difficult I know) and read the Rhino help information as though a newcomer.

Best of luck


Hello, Yes, my snap mode was based on old use of Autodesk. I have begun to play with snapping a bit more and it is getting better. It just seems very wimpy, that it doesn’t really snap if you move even a bit off point. I am hamfisted sometimes so it is probably my need to be a little slower in movements etc. I did change the distance that it is supposed to hone in to .5 mm from .25 mm. The part that gets me is that I will be .0025 mm away for an endpoint and another endpoint and it can’t find the bloody point. That is what is making me nuts. I am attaching a screen print from the options page, there are discrepancies i would like answers on.
Thanks in advance. dennnis

Hello - snapping is pixel based, not distance based - I am not at all clear what you’re referring to here. Your image shows only the Mid snap active - end is out of view. Is that what you expect.
See Help for information about Ortho angle and the other settings on that page.


Hello, I had a hard time getting all of the info into the screen shot. Yes, end point is on as is Ortho and Gumball. I was more concerned with the fact the the options screen doesn’t register that the Ortho is on, so is it really on? d

Hello - Ortho is on if the word Ortho in the status bar is Bold and off the text is Normal. Clicking there in the Ortho pane, or using the Ortho command (F-8 by default) will toggle the state. Options should indeed reflect that state in its checkbox.