Need Rhino Help With Rendering Shadows

Hello, I am pretty new to Rhino and have only been using for about a few weeks. I am trying to render in raytraced an architecture model with a shadow on the ground plane and a transparent background. Previously, I sort of set up my own ground plane with a surface set to “receive shadows” and that only took about 20 minutes to render. However, once I put it in photoshop I realized that the background wouldn’t be transparent so I realized I would have to rerender. I deleted that ground plane surface I previously used to create shadows and went into display properties. I clicked ground plane settings to “custom” and clicked on “shadow only”. It’s now been rendering for about an hour and it’s only at 50/1000 cycles. Is this normal? I’m completely new to this, I’m wondering if there’s something I did potentially wrong with the settings.

Please post the results of the Rhino command _SystemInfo