Rhino Mac wip Wacom tablet bug

There is a bug in the rhino mac WIP using with the Wacom tablet intuos pro.
The objects snap doesn’t work. With the Rhino mac 5 all work well. Please resolve for the next WIP release, thanks, Roy

Hi
Here the O Snaps works fine on my oldish machine, with the latest WIP build and Intuos Pro M
Just an uneducated thought; have you updated to the Wacom’s driver and firmware recent update?

Akash

Hi Akash,
thanks for your message.
Yes, I have all the latest drivers. With previous Wip Osnap worked for me but with last Wip, not more. With regular Rhino 5 Mac it works fine too.

Roy

Hi Roy
Then I have no idea, as Osnaps works here.
Best if you move your post to the Serengeti Mac category [since it is an issue with the WIP]
it would be easer for McNeel support / Dev. to see it and help you.

best regards
Akash

Hi Akash,
these videos show the osnap issue with Rhino mac wip here. Unfortunatly Mcneel is a very small INC so sometimes we need to wait YEARS (yes, …) to resolve some bugs. I love Rhino, less the Roadmap slow as a tired ESCARGOT (i’m in France now…), and the Mac version Roadmap is slower then the stupid (for me of course) Microsoft Windows version.
Have a nice day,
Roy
https://aws1.discourse-cdn.com/mcneel/uploads/default/original/3X/c/0/c026975e9e9c9bd5a0c283007569a67b9fe115e2.mov https://aws1.discourse-cdn.com/mcneel/uploads/default/original/3X/0/8/08aa92ee88407b42d64ee591281d1d09f419a998.mov

p.s. i’m not sure to upload movies here…i just try now

[another guess] Maybe something changed in your Pref. Snap setting? perhaps the snap radius is too small…
here’s my setting:

Akash

Are You using a Wacom tablet Intuos Pro?
That’s the bug, Akash…using the mouse all work for me too. The bug is related to the Wacom tablet and the last Rhino WIP.
Roy

Hi Roy
yes [as mentioned in yesterday reply]
I hope someone from McNeel will come to help you soon.
They may need your rhino info [About Rhino > More info] to paste into the post.
all the best
Akash

Hi Akash,
Ok, thank you.

How did you set your Rhino interface colors and appearance ?

Roy

Hello - I’m checking to see if we have one of these available - it looks like not, at the moment…

-Pascal

Hi Roy
these are options in Mojave Dark mood [option>general] + Rhino options> theme and colours.

Best to ask this UI stuff in another thread so you have better chance to have your Wacom + Osnaps issue resolved .
thanks
Akash

Hi Roy,

I tested Osnaps using a Wacom Intuos Pro tablet in the Rhino 6 WIP for Mac in OSX 10.13.6 and they worked as normal. I then tested in OSX 10.14.2 thinking maybe there was a Mojave issue but Osnaps still work as expected here. This is my Wacom driver and Rhino WIP info. I will see if I can find a tablet setting that may interfere with Osnaps in the WIP.

hi brian,
it seems here that the problem is about some specified files. if i start a new project in rhino wip. osnap it works, if i import some files from rhino 5 or older files it doesn’t work. Anyway i’ve decided to use only rhino 5 waiting when rhino 6 will be out.
thanks,
roy

Thanks for the update. Could you share one of these here or upload it to https://www.rhino3d.com/upload with a link to this forum thread in the comments? I’d like to make sure we fix this if it’s something we can. Thanks!

Hi Brian,
I sent u the file,

Roy

1 Like