Named view disappeared while modifying its name

Hello guys,

I found a strange bug during using the “named view” panel.
Once I save a named view and click on it to modify its name by typing the “del” key, suddenly the saved named view disappeared and it’s impossible to restore it by the “undo” command.

This strange bug appears from the Version 7 SR22.
I tested with several version and the SR19 and SR21 worked well but the SR22 and SR23 have this bug.

Can you check this issue and fix it?
Many thanks in advance.


Hi -
Could you change your update frequency to Service Release Candidates and test this with the latest SR24 Candidate? A similar bug with Named Positions appears to be fixed on the Rhino 8 WIP and I can’t reproduce the issue you are describing on 7.24.


I installed the SR24 and there were the same same issues and more.

Named View : The same issue (the saved named view disappear when I put the Del key to modify its name)
Named Position : Same as Named view’s issue.
Named CPlanes : Same as Named view and Named position’s issue.
Named Selection : A little different issue ; when select a selection one more time, it change to let us type a new name, but when we click one more time it become impossible to type. The only way to change its name is to put the backspace or del key and retype its whole name.

BTW, concerning the Named view issue, it doesn’t occur when the view mode is in Thumbnail.

Hope that a SR25 will be released with those bug solved.
Best regards,


Hello, I updated Rhino7 to SR27 and this bug still appears.
I use often “Named View” and it’s quite tiring to be really careful about renaming them.
Can you confirm that you are treating this bug?
Thanks a lot.