Named Positions Not Saving?

As the title says, NamedPositions are not saving, lost hours of work last night :thinking::crazy_face:. Just ran a test file to confirm this morning, same outcome, save a file with NamedPositions, close Rhino, re-open file, nada, zilch, no NamedPositions saved ??

After some more quick testing, the problem seems to be with 6.25. If I use 6.24 it saves the NamedPositions. Not tried with V7WIP, no time at the moment :+1:

Can you please provide us with a smallish file and instructions to follow to repeat the problem?
If I can repeat it here, I can get a defect report to the developers and get it on the pile to be fixed.
Thanks

Hi John, ok just tested this again, same result, this file had 2 NamedPositions when I saved it. I closed the file, re-opened and they have disappeared :thinking::thinking:
np test 2.3dm (2.8 MB)

I need the file prior to the problem, WITH the named views, so I can try opening and saving it to see them missing.

I need to duplicate the problem.

I created two named positions in your file, saved/closed the file, and reopened it.
The NPs were there.

Are you saving the files on your local SSD/HD?

Thanks

yes saving to desktop on MBP, here’s another test, same result, loses Named Positions, try it a couple of times, close Rhino 6.25 completely, then open application again, and select recent file from splash window, Named Positions disappear, nada, zilch, gone !
np test 3.3dm (2.7 MB)

Sorry to be a pest, but I’m missing some crucial step.

If I open your new file and close it, nothing was changed so there’s nothing to Save. The file just closes.
To get it to Save, I need to add a bit of geometry, then close, and I’m asked if I want to save. I click Save and reopen the file, the named Positions are still there.

Are you using Export and making a new copy in a new location or something else?

I’m running a slightly newer in-house 6.26 build. I’m not aware of any new changes.

No exporting or importing, just a new file, add some simple geometry , add a NamedPosition, then jumble the geometry around a bit, add another NamedPosition , save, close Rhino, then open again

I think the critical step in reproducing this is closing and restarting Rhino. I tried to reproduce it several times by just saving, closing, and re-opening a file and couldn’t reproduce this bug. But the first time I saved, quit Rhino, re-started Rhino, and opened the file - all Named Positions were gone.

-Kevin

1 Like

yep, close the programme, then re-open file, all NP gone :crazy_face::crazy_face:

Bingo!
I can reproduce it.
https://mcneel.myjetbrains.com/youtrack/issue/RH-58609

1 Like

This is strange.

If I open the file that I was experimenting with above in Rhino V6 (6.26.20133.11312, 2020-05-12) it looks like it has no Named Positions.

But if I open the same file in the V7-WIP (7.0.20133.12126, 2020-05-12)
the Named Positions are still there. Apparently they are just not being seen when the file is opened in V6.

-Kevin

1 Like

yeh, just opened same file in V7 WIP and the NamedPositions are there, strange but true :+1:

I just rolled back to 6.24 and the problem exists there too.
This doesn’t seem to be a regression.
Still a bug, but not a new bug.
I tested this in Catalina 10.15.4

1 Like

RH-58609 Named Position: Closing a file with NamePositions, then Quitting and restarting Mac Rhino deletes the saved named positions in the file

should be fixed in the latest Rhino 6 for Mac Service Release (6.27). Thanks again for reporting this!