My polisurface won't close -- Please help!


#1

I’ve made my arquitectural volume for my presentation on monday and need to export it as STL in order to print my model, problem is despite having close every single naked edge, there are still 2 dots which won´t let my make it into a closed polysurface. Please someone help!!!


(Pascal Golay) #2

Hi Isaac - see if the test command

testRemoveAllNakedMocroloops

works on this object. Copy and paste or type the entire command, it does not autocomplete.

Anything good happen?

-Pascal


#3

Hi Pascal,

Thanks for answering so fast. I tried the test command but it says “unknown command”. How can I make it work or is there any other thing i could do?

  • Isaac

(Pascal Golay) #4

Sorry! - thumby typing - it is testRemoveAllNakedMicroloops

-Pascal


#5

Don’t worry… I am not sure why but it still appears as an unknown command.


#6

You are aware, aren’t you, that all test commands must be entered completely and exactly correctly?


#7

Yes, I copy and pasted it just like Pascal indicated…is there anything else i could try?


(Pascal Golay) #8

Well, let me just verify - I hand this command out regularly so I kind of have it down, except for the typing… Yeah, works here, pasted from my note above… I’m not sure what to suggest - what service release of Rhino are you running? (Help > About Rhinoceros) If it is not 12 or 13, please install the latest from

http://www.rhino3d.com/download/rhino/5/latest

-Pascal


#9

In fact my rhino version was quite old (SR5). The test command did work once I updated!! But one of those naked edges is still there therefore keeping my object as an open polysurface. After a couple more of attempts it finally gave up and it is now a closed polysurface ready to be exported!

Thanks Pascal!


#10

Spoke to soon, when turned to a mesh it comes out as an open mesh :confused: is there rapid way to turn it into a closed mesh?


(Wim Dekeyser) #11

Does the FillMeshHole command fill those up?


#12

Solved it by using MatchMeshEdges and then FillMeshHoles. Luckly it is finally done! Thanks everyone!