Multiple inputs with VA GetObject


I created a Grasshopper command to subtract beams and columns intersecting a slab. I was hoping to use it on one or several input beam/column objects but the VA GetObject only allows selecting one object before it jumps to the other input (the slab). I can window select many objects, which is OK, but I’m wondering if it is possible to allow sequentially selecting multiple column/beam objects?


Hi @Filipe_Brandao what you are trying to do should be possible right now. Make sure you have more than one item at the “at most” settings of the VisualARQ Get Object component:

If the problem persists, please share a file we can test to figure out what’s happening.

Hello @fsalla ! Yes I have. As I said, I can select multiple items with window select or by preselecting them, but I can’t select several elements by clicking. I was kind of expecting the same behaviour as the GetNumber component, where you hit enter to accept the user input. (23.3 KB)

Hi Filipe, I don’t know why, but the problem is in the “At most” number you entered for the first “Get Object” component…

I guess you wanted to make sure you didn’t fall short :laughing:. I’ve tried it with “1000” and it worked out well!

Thanks Francesc!

Actually, I just tried to clear the value and it defaulted to the largest 8-bit integer. I figured that I couldn’t go wrong with that :smiley: . It turns out I can!