Moving objects to different layers, peculiar behaviour

layers

#1

I’m working on some basic frames, doing slight variations before deciding on final option, so i am moving different options to different layers, then hiding the layers while I work on a different variation. It seems only part of the surfaces I select are changing to the correct layer colour ?? In the screenshot only Layer 2 should be visible (purple). Very strange, any ideas ? tia
edit- this seems to be happening in both WIP and commercial release, running both up to date versions,


(Pascal Golay) #2

Hi Milezee - I don’t see what you’re trying to point out… but the layers below the purple one are on.

-Pascal


#3

Hi Pascal, there is nothing on the blue, green, and white layers, if you look at the screenshot the surfaces are showing up as purple and black, and the default (black) layer is switched off ? It’s confusing why the purple layer is showing both purple and black if that makes sense ?


#4

Color can be attributed by either layer or by object. Attributing a color directly to an object overrides its layer color. If you select one of your black objects on a purple layer, what does it say in the “Display Color” box?

–Mitch


#5

Hi Mitch, I’m just selecting objects and and assigning them to a different layer, I have never encountered this before, I’ve just tried creating a simple box on a blue layer, and that is now only showing as black, I’m even more confused ? I’ve just noticed something, curves seem to be fine, its the edges of surfaces and poly surfaces which are staying black, if I turn on isocurves they are showing as the correct layer colour, but the edges remain black ? Maybe something in my preferences ? test file attached
layer colour issue.3dm (2.8 MB)


#6

Silly me, I had set certain preferences for some ‘Pen’ PDF’s I created the other day, and left them set at ‘black’ for the edge colours, school boy error, appreciate you and @pascal trying to help :blush:


#7

OK, yep, I was just typing an answer to see if you changed something in your display mode(s)… --Mitch