Moving/copying set distance no longer confirmed by mouse click

When typing a set distance to move moving/copying an object, previous versions could be confirmed with a left mouse click. Now only a space/enter confirms, with the left mouse click moving/copying to where the cursor is, not the typed distance.

Seems like a pretty fundamental change of how Rhino works - has a setting sprung on/off in my settings perhaps?


I can not confirm your observations on how Rhino used to work.

I drew a circle, selected it, started Move, selected a point to move from, then typed “2”, and left clicked.
The 2 was ignored and the circle moved to where I clicked.

If press enter or right mouse click After typing “2”, then the Move is constrained by the 2 distance.
Then when I left mouse click all I’m showing Rhino is the direction to apply the 2 distance.

This is how Rhino has worked for a long time.
I just checked this in V4, V5, and V6.

What are you doing differently to have this conclusion?

So you have SmartTrack on? If SmartTrack is currently tracking, Rhino will consider that a valid direction vector, and as soon as you give a distance, the move will be made (as it has a direction from SmartTrack).


It’s strange, for me clicking to confirm distance works randomly both with Smarttrack on and off.

It feels like muscle memory to me, and I think I have been doing this for years, but perhaps not.

For me, if under Rhino Options -> Modeling Aids -> SmartTrack and Guides, if I clear Smart ortho and Smart tangents and perpendiculars, I no longer get the move as soon as enter is hit on a distance.

Hi, having the same issue right now. Probably happened after the update. Problem also involves gumball moving. It’s super annoying. I tryed to import my old settings, but it didnt solve the problem. Is there any solution, or i just have to relearn it again?

Hello - you can get the fixed (7.5) version by changing the ‘Update frequency’ in Options > Updates and Statistics page to ‘Service release candidate’.


1 Like

Perfect, It works! Thank you Pascal