Move objects to this layer -> change object layer

This seems like a real retrograde step, but in v7 WIP, I’ve just noticed that the context menu to move an object to a layer in the layers panel has changed the wording from:

“Move objects to this layer”


“Change object layer”

It seems to me that the old wording is really clear. Hard to misunderstand it. It is unambiguous.

The new wording is really unclear, to the point that I really do not actually understand the language being used. I mean, I worked it out, but the words used in that arrangement do not actually describe what is happening with the command.

Please revert it back or if there is a good reason for changing the wording, then please find something that actually makes sense.



Matches the Windows version, which has always had that phrase.

There is also the question of the use of the word “Move” in this case as the objects in question don’t actually move anywhere, they just change layers.

I suppose it depends on how you conceptualise layering. ‘Layer’ as a word derives from a physical thing and they are displayed spatially in a hierarchical list. So whilst from a technical point of view, the properties of an object that describes which layer it is in may simply be a piece of meta data and therefore ‘change’ being appropriate terminology, from a UI perspective it is moved.

And as people interacting with a GUI to work on a digital representation of physical objects, it seems entirely reasonable to use ‘move’.

I can see a reason for standardising, but the new (old?!) wording is very poor indeed. If they’re going to change something, it should be to make it better, not worse.

One other thought. The contextual menu is from the layer panel. That is part of the problem. You can’t describe changing something to the layer when the context is that you’re interacting with the layer. The English is just all wrong. Hence why move makes so much more sense. To make ‘change’ work it would have to be something like this:

“change layer of selected object to this layer”

Which is far too long.

Dunno, the use of the word change always seemed logical to me, personally I never found it misleading.

When you start typing Move… at the command line (well, the command search on Mac) what do you see? Nothing involving layers, all the commands concern actually moving objects around in Cartesian space…

OTOH, if you start typing "Change… you will get ChangeLayer and ChangeToCurrentLayer. So these commands would also need to be renamed, and if they start with Move, then they will get mixed in with commands that actually do move objects. I find that confusing.

But typing a command is very different from a context menu in a GUI. You’re interacting with a visual interface and the whole point of a contextual menu is that it changes based on the context. Otherwise it isn’t a contextual menu anymore.

When I right click on a layer, I don’t expect the wording to match what I would see or type in a command line interface. If we did expect that, then everything in all menus would be written exactly as they are in the command line. Which they clearly aren’t.

For example, you cannot type deleteLayer because which layer would you be deleting? You can’t type selectObjects to select objects on the layer because which layer’s objects would you be selecting? Which comes back to the point of contextual menus. They allow you to interact in ways that don’t make sense otherwise.

Sure you could, if there was actually a command for that, it would just bring up the layer choice box to choose which layer(s) to delete. The -Layer command already has a Delete option, so one could make an alias ‘DeleteLayer’ with the macro ! _-Layer _Delete _List.

This one does exist , it’s called SelLayer and it does the same as above. Brings up a list and even lets you select an object to select the rest of the objects on that layer.

But I’m not going to argue further on this. I don’t think it will get much traction; you noticed this because something changed between what you were used to previously and what it has been changed to. The same would happen the other way if the thousands of users on the Windows platform who are used to this wording since day one were to suddenly find it changed.

Command descriptions and wording aren’t always the best, I work in Rhino in 3 different languages and there are translation oddities and ‘funny’ descriptions in all of them. It’s something you learn to live with and move on. Why is Loft called that? It has nothing to do with what the command actually does - except for the historical reference. At least in French it is called “Surface par sections” - which is exactly what it does. But I find that command name way to long for my taste. It is what it is…

Both of those bring up a separate GUI panel that exposes a layer list, much like the layer panel. So it isn’t really all happening in the command line.

Making an alias that fits your own preferences for how to name a command is really somewhat different to changing a contextual menu description from something that made sense to something that categorically does not make any sense. It is awful grammar and it doesn’t even use words that describes what it does. It is awful.

OK, it’s awful. As my kids say “get over it”. Mitch and I and thousands of others aren’t going to take kindly to a change made because you think the original is “awful”. We “got over it” a couple of decades ago. It’s called “learning a new software”.

1 Like

I’m going to moderate my language here but there is absolutely no reason to be a dick.

You have no idea how long I’ve been using rhino.

I just happen to have been using rhino on Mac for well over 10 years and have become used to the terminology used in it. OK, so the windows version might have used different wording for longer (and yes I used it before the Mac version).

Personally, I’d always ALWAYS change something that’s bad to something better, regardless of whether it annoys some people. It isn’t about what I’m used to, it’s that it’s got WORSE. That’s just unacceptable.

I would too, but we’re talking about the Titanic here, the sheer weight of all the users in the world now resists making any sharp turns, even if there are perceived icebergs ahead.

This however remains your personal opinion - which you are entitled to of course! - there are also people like me who don’t have a problem with the current wording.

It is now grammatically incoherent. Previously it wasn’t. There was no ambiguity as to what the old (as in on the Mac) wording meant. Language and UI should be about avoiding ambiguity, at least for something as prosaic as a tool like Rhino.