Move all objects on the same bottom level Z value (ex Z=0)


I will be deeply grateful of any piece of advice/guidance on moving/aligning all objects (see attache file) on the came bottom level.
I am beginner and it seems that it not as evident as it should be.

I have tried align-bottom command in vain.
Certainly there is something wrong between the chair and the screen.

Thank you in advance for if possible any prompt help.
Many than ks in advance.

Hello - most likely, use the Align command in a front to right view.


This what I have been trying for an hour.
Align - CTRL+A - bottom.

With no results. Same position of all selected objects.

Hello - you need to tell it what the alignment point is - you can click anyplace or type in a point coordinates. Typing in 0 and Enter will align the origin.


Cannot get it work.

Select objects to align
(…) Press Enter when done
Alignment type (…)
Click on Bottom
Nothing happens.

There is no prompt for an alignment reference

yeah… it worked the first time on all but on reopening the file, does exactly what you describe - it does work in sections. I’llsee if I can figure out what is going on. Can you make say 1/3 of the objects at a time behave?


Oh, thank you.
The objects come from Lands Design insertion.

I will try align them partially.

In what prompt, moment I can insert Z 0 coordinate as a target bottom point?

Hello- just ‘0’ or '0,0,0’and enter.

It seems the problem is in the cursor location - if the cursor is off to one side when you run the command it works (here) but if the cursor is over the objects it fails. And sometimes not… I cannot tell, my guess is it is the sheer number of objects that is making this problematic.
RH-66127 Align quits with a lot of objects


I cannot get it.

Once more.

Select objects (1/4 selected in a front view)
0 (for Z)

Selected object are aligned horizontally.

There is sth strange with axes. See attached pictures, please.
Depending on the selection in a view Z axe changes its orientation (vertical/horizontal).

Hello - Set AlignTo to Cplane and make sure the active view is Front or Right when you run the command - maximizing the viewport makes this easier.


There is no option - CPlane.
ToPlane asks for 3 points…

Would it be easier to record the way you achieve the bottom alignment of all the objects, please?
It could serve to other newbes and save your precious time.

Here is the Align to options.

Finally, do not know how it works. Align-Bottom-0 within front view.

Thank you.

Please click the AlignTo command line option so that it reads AlignTo=CPlane.


Some scripts that might be useful… (2.3 KB)

Aligns a set of objects lowest points to World 0.
Indivudually(default) - each object is aligned to 0 individually
(group relationship is not preserved, objects move separately)
AsGroup - lowest point of the group is found, that point is aligned to 0
(group relationship is preserved, objects move together)
If objects preselected, previous or default setting is used. (2.6 KB)

Aligns a collection of objects’ bounding box bottom to a point in world Z
Point can be a picked point or a keyed in World Z value.
Option to transform objects either individually or as a group together.


I do thank you very much.

How one can install it?

Short version -
Save the script somewhere on your computer. then

  1. Type _RunPythonScript and browse to the script file and open.
  2. Create an alias with ! _-RunPythonScript ""
    (including the file name and extension) Then type the alias to run the script.

Detailed information here: Integrating macros and scripts into your workspace [McNeel Wiki]

Once more huge thanks.

Got it.
Meanwhile I found the same source.

Now… the alias.

Options>Aliases; New
Type the keyboard shortcut in the left hand box, and the command string above in the right hand box and OK.

I will not have enough thankyous…

Thank you.

Hi @GThib,

Your file contains 55 bad meshes. You can find these using the SelBadObjects command.

Several of these bad meshes are failing to produce a valid bounding box, thus causing the Align command to fail.

If you run SelBadObjects and then Hide , then Align, all works as expected.

Hope this helps.

– Dale


Thank you. I will keep it in mind.

I am full of admiration.
A bit discouraged.
I have got only one life to learn it and fulfill almost all my wife’s wishes

1 Like