Mouse wheel zoom stutters in rendered viewport

Is it just me or is the mouse wheel zoom broken in a rendered viewport? (crtl + right click) dynamic zoom works fine though. the problem is only in a rendered view port. ghosted and shaded view ports are fine…
weirdly if i pinch zoom in on my touch screen the response is smooth like dynamic zoom?!.
the problem is the same when zooming in with the laptop touch pad, and i have also tried 2 other mice to no avail, they all stutter.

Is there a way to fix this so i can zoom smoothly with the mouse wheel?

here is a video of the issue:

mouse wheel stutter

here is my system info:

Rhino 6 SR16 2019-7-9 (Rhino 6, 6.16.19190.07001, Git hash:master @ a8b4ee102e9e0eb1d11825df063e13f96d518f93)
License type: Educational, build 2019-07-09
License details: Cloud Zoo. In use by: dblack ()

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: DESKTOP-CQNVUK2

Hybrid graphics system.
Primary display: Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 3-8-2019 (M-D-Y).
Primary OpenGL: NVIDIA Quadro P2000 (NVidia) Memory: 4GB, Driver date: 3-18-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 419.72

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-18-2019
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Users\Dakota\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\CreateQuadMesh (5bf6c0f3-3657-4ad5-834a-bbbb52706a40)\6.0.6950.16446\CreateQuadMesh.rhp “CreateQuadMesh” 6.0.6950.16446
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\KeyShot8RhinoPlugin (6c7d7caf-b4ba-406d-bfaa-8d719d8212c3)\\KeyShot8RhinoPlugin\Rhino 5.0\KeyShot8RhinoPlugin.rhp “KeyShot8RhinoPlugin”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hello - hmm… here, my mouse scroll wheel has detents and it clicks as I scroll - if I go somewhat slowly, I see the steps according to:

Options > View page > Zoom > Scale factor (smaller number is more chunky, .9 is default)

In short, I guess I do expect to see steps, and it may be that the rendered view is slower to redraw or something - does it smooth out if you turn off the skylight?


Hi Pascal,
There is one more thing to consider - the scrollwheel zoom is not doing any of the view degradation that all other view changes do (for example skylight shadows downsampling). My understanding from what Steve and Mikko said it is hard to implement, but apart from “steppy” movement, the redraw will be slower.

EDIT: looks at the video, this is expected behavior with mouse wheel zoom (well, its not a real zoom, lens don’t change, it just moves the camera closer). Maybe you can play with the setting in Tools>Options>View>Zoom scale factor. The closer to 1 you get, the smaller the step will be, but slower zoom I guess. Maybe messing with mouse wheel speed in the driver will help to balance that out…


Hi Jarek - ok, thanks - I guess then that I’d expect turning off skylight to help - that would be the big difference compared to other shaded views.


Hi Pascal, yes, agree - or, if you want to keep the skylight shadows but go fancy for faster view speeds, tweak two things - decrease the shadow quality in the display mode setting - you can actually get quite low unless you need sharp cast shadows, otherwise skylight will still look good.

And step 2: in Advanced settings, downsample the skylight (1=high quality, 2=medium - normally used for dynamic view changes, 3=lowest, fast but real quality drop).
I highly recommend changing your defaults to this for speed gain:



Thanks guys!!

so the slow down is definitely from rendering the shadows with the skylight on. turning it off made zooms super fast.
I got good results by reducing the SkylightShadowResolutionScale to 2 like you suggested and lowering the shadow video memory usage/ shadow size to 16mb.
its a bit grainy and not as fast as dynamic zoom… but a good fix for now.

The movement is still “steppy” but much more responsive. Is the steppyness due to a limitation of the resolution of a mouse wheel only sending a signal every so many degrees? or some legacy to the mouse wheel/ driver not being designed to be used to zoom in smoothly .

I would love to see an option to dynamically zoom with just the mouse wheel… but that’s probably a lot of work.

thanks again!

I don’t think this is in Rhino’s control - basically every mouse wheel step is a small “jump”, it is not smooth movement, so I don’t think it would ever be possible to make it as smooth as other navigation modes. It is kind of a bonus function, and AFAIK works similar way in most 3D software packages (never super smooth, but quick to access and easy to use).
Once the viewport display speed is good, using the wheel works nice - good to hear the tweaks worked on your end.


hey Jarek,
you are absolutely right that most 3D software zooms in steps. I guess i am just spoiled by the smooth scrolling enabled by high resolution mouse wheels these days. Maybe the issue is that cad software has not kept up with the integration of high resolution scrolling, like we see in modern browsers for example.
Another problem i often have is that unless i use dynamic zoom i can’t achieve the exact zoom level i desire, because the stepping results in a view that is either too close or too far away. this may not be a feature many users are asking for at the moment but i feel like it will be expected in the future.

Can’t speak for the implementation of the high resolution scroll wheel - I guess mine is still oldschool and quite “steppy” by default. Maybe @mikko can give us some insight if this is something considered for future Rhino versions.

As for getting precisely where you need to be with the zoom, you will have to rely on RMB+Ctrl or RMB+Shift+Ctrl that work quite smooth, and still just a click away, compared to any commands or menu icons.