Mouse Pick Object

test object selection
in Rhino 7/8


in Rhino 5

2 Likes

Hi:
What you’re seeing is when Rhino isn’t sure what you intended to select. It’s called the Selection Menu.
Normally, objects that are occluded in the view are rejected for selection. Are you using a Shaded, Ghosted, or customized working display mode? There are settings that can effect this behavior.
Retired versions of Rhino (V7 and earlier), will not be modified.
I recall there were some changes related to this behavior in V8.
Are you running the current V8 Service Release?

interesting, I am not able to reproduce that behavior in Rhino 7, nor in Rhino 8. Can you send me that model?

1 Like

Selection Menu does not matter. good result from command acceptance TestZBiasFactor 0.01 , but you need to test whether it corrupts the values of other processes.

Test.3dm (777.8 KB)

I suspect, like @bigpiper246 asked, that there is a custom display mode you are using. When I run this in shaded mode, all works as expected:

If that’s not the case, then you have some settings different on your end we need to figure out

rhino wip + shaded mode,


Rhino 8 TestZBiasFactor 0.01

in that case, pls run _SystemInfo and post back the results

1 Like

h1.txt (3.2 KB) monitor 4k 27 inches. :sunglasses: I don’t think it makes any difference to macOS same problem and also helps TestZBiasFactor 0.01

If possible, pls check if the problem persists without any plugins active. In any case I will ask our devs if they have suggestions.

Although this setting doesn’t seem to matter anything here, do you have Rhino.Options.Mouse.PickOccluded set to True instead of False?

1 Like

“Rhino.Options.Mouse.PickOccluded set to True instead of False?” I tested it. There’s no difference.

I think it will be better for me and my jewelry plugin if I create a script to run TestZBiasFactor when Rhino starts with the ability to change and save the factor in a resource.

Can you send me your Rhino settings? For this you can run _Reset (but don’t your Rhino) but in that dialog choose export settings, and send that zip.
image

That would be a workaround and not a solution, and certainly not running test commands unsolicited on other users’ computers.

1 Like

RhinoSettingsForSupport Rhino8.zip (2.3 KB)

that looks like a pretty much stock Rhino. Did you try without any plugins active as well?

1 Like

TestZBiasFactor tool was created and why it hasn’t been launched.?

that still doesn’t answer this question:

1 Like

One more question, what input devices are you using? Type/brand of mice, space mice etc.

1 Like

Yes, I did uninstall all the plugins and everything is working stably. Now I’m going to look for the culprit by elimination.

2 Likes