Mirroring vertically around x axis instead of horizontal


#1

Rhino suddenly started mirroring objects vertically around the x axis, while in the perspective view.

Before, it’s always been mirroring horizontally (to get the other half, left or right) of a design for instance.

Now I need to go to the top view viewport to do this, which is very annoying.

Any idea what could be wrong here?


#2

Have you changed the CPlane in the Perspective viewport? Mirror is CPlane dependent…


#3

must have been that. I clicked the “Cplane undo” button once. then tried to mirror and all was as it should be.

Thanks for the assistance…


#4

i notice that, while the mirroring issue seems to be resolved, lines will not draw in the XY plane when drawing in the perspective viewport, as it should by default. Now, lines are drawn vertically. Also, rhino doesn’t show the name of tools when hovering over them. Seems like quite a few things are “off”. Is there a way of resetting the file to standard settings? I don’t want to copy paste all in a clean file if I don’t have to.


#5

I suspect you still do not have the Top CPlane (default) set in Perspective - I might just reset all views by running the command _4View TWICE (in a row) - see if that helps restore the drawing stuff to “normal”.

I don’t think this is related to the other problem, and doesn’t sound if it’s file-related at all. What I might do is save the file, exit Rhino and re-open the file and see if things aren’t better.


#6

ok that worked!