Mirrored text in r7 and r8 whatever

good evening,

i had to mirror some sections in rhino 7 and noticed that all the text was mirrored. so tried that with new text in r8 and the text was not mirrored, good.

after opening the rhino 7 file in r8 i noticed that the text created in 7 is mirrored and therefore unreadable, all the new text created in r8 was cool and not mirrored.

do i miss something here or is this working as intended?

best
Benjamin

ps: there is something fucked up with the line types!

mirror.3dm (81.2 KB)

In your named annotation styles on the Font page, there’s a setting labeled
“Text reads forward when viewed from behind”.

Maybe that’s what you’re looking for?
image

1 Like

hey Brock,

thx, this is checked, makes no difference.

cheers,
Ben

Please post a small specific example file that shows the problem, together with any steps needed to repeat it.

Also, include your Rhino SystemInfo so we know what resources Rhino sees.

Thanks

it makes a difference, but only if I create a new annotation style in r8 and check “Text reads forward when viewed from behind".
text created in r7 is not affected by this option.

mirror.3dm (81.2 KB)

Rhino 8 SR2 2023-12-12 (Rhino 8, 8.2.23346.13001, Git hash:master @ dbefe46c12cda06610a9ab683a211aa3d16f0030)
License type: Testversion, build 2023-12-12
License details: Cloud Zoo
Expires on: 2024-01-30

Windows 10 (10.0.19045 SR0.0) or greater (Physical RAM: 32Gb)
.NET 7.0.0

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 2080 SUPER (NVidia) Memory: 8GB, Driver date: 10-26-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 546.01
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-26-2023
Driver Version: 31.0.15.4601
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\ProgramData\McNeel\Rhinoceros\7.0\Plug-ins\Datasmith Rhino Exporter (d1fdc795-b334-4933-b680-088119cdc6bb)\DatasmithRhino7.rhp “Datasmith Exporter” 5.2.1.0
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V8\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.2.23346.13001
C:\Program Files\Rhino 8\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 8\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.2.23346.13001
C:\Program Files\Rhino 8\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.2.23346.13001
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.2.23346.13001
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.2.23346.13001
C:\Program Files\Rhino 8\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.2.23346.13001
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.2.23346.13001
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”

thank you, thats good enough. you just put all the text on a new annotation style, thats good.

well, that works with the annotations styles from r7 too. you just have to uncheck “Text reads forward when viewed from behind", close and open, then check again.

that works for me.

That sounds like a fairly painless work-around, but it still sounds like a bug to me.
If I can repeat it, I’ll post the YT number back here.

Thanks

It’s working okay here for me in V8 in an in-house build that will eventually be released as SR4. I’m guessing this was reported and has already been fixed.
Front:
image

Flipped:
image

1 Like

good afternoon,

thank you. did you notice that the line style dash-dot seems to not working any more?
a sample is in the file attached above.

Benjamin

good afternoon again,

the main disadvantage of the “Text reads forward when viewed from behind" - solution is, that the text elements in plan view dont know any more how to orient.

so you have to make a decision here, either you want your text not mirrored OR you want your text correctly orientated. sometimes you just dont want text to read forward when viewed from behind, you just dont want it to be mirrored.

in fact i made the decision, for now at least, to not use this option at all.

imho the only real solution is to introduce an option to simply NOT mirror text.

Benjamin

That is what the check box is for in the named Annotation style.
When it is unchecked, the text stays put.
When the option is checked, it pays attention to the current display.

Hey Brock,

thank you for answering at the weekend.

I fully understand the reason why there is such an option. It definitly is very helfpul in any case where you are dealing with annotations in a 3d model, because nevertheless in which view you are working the annotations are always facing perpendicular in the camera direction. thats good, no question.

what i am currently doing here is that I am creating a conceptual 2d drawing with alot of sections and layouts and everything, for different scale. so that is the base on which we are working at the moment, this is what we are printing out for communication between different team members, so they can understand the set out of the project.

still, there is no 3d information included.

From my understanding what would be really helpful is system variable like in autocad, where you can disable text mirroring.
.

enjoy your weekend,
Benjamin

hey Brock,

any news on this?

thx,
Benjamin