Unwanted mirrored text

I don’t quite understand a lot of things about the new text stuff in R6 but this one is causing me issues. Text is mirroring when I rotate the view and I don’t know how to stop it. I have multiple texts in the file and I can’t worry about where my camera angle is to make text view correct.

Here’s two images overlayed into one image showing how a slight rotate in the view casuses that mirroring effect.

Also heres the file:unwanted mirroring text.3dm (627.2 KB)

Make sure this Annotation option is turned on:

You may have to rotate the view around for it to update.

Thanks tried that it didn’t work

Strange. It worked fine here for me.

Version 6 SR11
(6.11.18348.17061, 12/14/2018)

Whats it doing in the front view?

It wasn’t rotated around quite far enough to trigger the flip.

Will you rotate the viewport around so the camera is close to the view I showed? It looks fine from the left and right but right where the camera is parallel to the label it turns over…

My image isn’t two labels, its two images of the same label overlayed so I was posting just one image

Looks like itll be another workaround.

What happens if you turn off the mirroring in the named annotation style?
As far as I can tell, the tool is doing exactly what it was designed to do.

You seem to have a specific situation where it isn’t doing what you want.

Ok I don’t know whats happening. It works by turning that off. I would have sworn I had it turned off to begin with. I’m gonna start another thread on some different text probs. Thanks for your time I appreciate it.

Cool. I generally run with that off myself, and change the CPlane if I want something special.

Some people really like that relatively new option.

Hi @John_Brock,

Can this be logged as a bug please. The flip is kicking in far too soon, well before the back comes into view.


1 Like

How does this make any sense?

Hi Jeremy, Asterisk, Jason and all,
This just came on my radar here.

I would like to get this logged as a bug.
Could someone please provide me with a small file and a procedure to duplicate the issue? Also include the version of Rhino you are using.

Sorry about the issue.
Thank you for your help.

Mary Ann Fugier
Robert McNeel Technical Support

@jeremy5, @Asterisk, @jasonh

It clearly does not make sense.
So far I can not recreate the reversal of the text as you showed.
Is that wall vertical and coplanar with the viewport CPlane when you created the dimensioons?

Did you create them separately, or all at one time using the continue option?

Hi @mary,

This was a while ago and I didn’t keep my original experiments, but here is a variant of the OP’s file posted above. Only change has been to zoom in. If you use mouse right button to rotate the view right and left you should see the text flip, then come back to face forward.

I just tried this in 6 SR 17 (6.17.19218.13231, 06/08/2019).

unwanted mirroring text 2.3dm (631.8 KB)


Try unchecking this option:

Hi Jeremy,
Thanks again for the file and video.

In our tests here, it seems like the mirror issue is better with sr18.
With 6.18, we can open your file and it is not mirrored on our Rhino.

Here is your video.
Here is mine.
We would like you to try the daily build of Rhino called “trunk” .

This is how, you can get the daily trunk build:

  1. Start Rhino
  2. Run TestEnableDailyBuilds
  3. Go to Options->Updates and Statistics
  4. In the " Update Frequency " dropdown, select " Trunk (Daily )"
  5. Then click the " Check Now …" link just below the dropdown…

That should take you to the latest version of Rhino.
Please download and install it.
Test and let us know if that helps with the annotation text issue.

At some point, you will want to return to the service release candidate or the service release . This way you can let us know if this helps as soon as possible.


Max Fugier
McNeel Technical Support and Training
Seattle, WA