Minimum edge length not working fully on export

I was very glad to find the “minimum edge length” setting on .obj export, but a bit sad that it doesn’t work in all instances:


Also, it seems that some fillets can become really ugly at low settings:


This is at a different part in the file, and here it looks ok (very well in fact):

For reference, here’s the settings I used:


And here’s a sample of the surfaces:

minimum-edge-distance.3dm (503.4 KB)

I recommend you to play with the “Maximum aspect ratio” (anything between 3 and 6 usually work on most scenarios) and “Minimum initial grid quads” (I would use 16 as a minimum, because that means 4x4) options. Also, “Maximum distance, edge to surface” should be less than 1 (I often use 0.01 or 0.001) to give you more accurate results around bumpy areas and fillets.

Sorry if I wasn’t clear, I’m trying to get down to an as low triangle count as possible for VR purposes.

OK, got it. Then maybe trying various settings with “Minimum initial grid quads” will give you best results while keeping the polygon count as low as possible. But I would still use “Maximum aspect ratio” of 5, because I noticed that your screenshots show issues where the edges are 6-7 times or longer than wider. Keeping the “Maximum aspect ratio” at 5 will reduce the amount of these odd looking areas.

1 Like

Ah, so that’s what maximum aspect ratio does. I’ve never seen that before, so that’s amazing.

Unfortunately, it completely ignores “minimum edge length”.

In fact, I’m having a difficult time enforcing “minimum edge length” at all, because even if I set everything else to 0, which should mean that there’s no restriction on anything else, minimum edge length still gets ignored in many places:

Even just using the aspect ratio and edge length, and nothing else, seems to create a lot of weird singularities:

(Still using the same example file posted above.)

If you remove the tick marking from “Refine mesh”, it will heavily reduce the polygon count. “Refine mesh” is used to… ummm… refine the mesh. With other words, it adds plenty of new polygons in areas that are supposed to be rendered with a finer detail, hence the extra triangles you see across the rounded corners.

The right side of the edge from your last screenshot has an excessive amount of polygons due to the false edge joint that Rhino did to force both edges to be joined together. If you run “Explode”, then “Rebuild edges”, then “Join”, and finally “Edge analysis”, you will notice that some of the surface edges can’t be joined as they don’t match close enough within the tolerance setting of your scene. That same right side edge that I mentioned above is getting much cleaner meshing after the rebuilt edges. However, some other edges are now exposed (non-joined) unless you fix the with the “Match surface” tool. In case that you don’t want to change the geometry and keep it intact, my recommended mesh settings for this particular model are:


P.S. 1: In general, if there is some area with too dense meshing, this means that the NURBS geometry is messed-up there and reworking it will reduce the polygon count and improve the tolerances between surface edges.

P.S. 2: On the Polygon mesh detailed option window the “Density” setting is sort of a quick multiplier of some of the other settings below it. That said, “Density = 1” will roughly have 2-4 times the amount of polygons you have with “Density = 0.5”. “Density = 0” will completely turn off the multiplier for the rest mesh options.

1 Like

Thank you so much for the detailed explanation. You are correct, other models created a much better mesh with no singularities… this surface is, of course, imported into Rhino, and I can’t explode and stitch everything that comes my way, so I’ll try to experiment with document tolerance settings as well and see if that affects the mesh in any way.

1 Like

Seems like this might be a good test case for the QuadRemesh in Rhino 7.0 WIP?