Meshoutline issue

I am getting some strange behaviour when using Meshoutline on a closed polysurface. The issue becomes apparent when offsetting the curve produced where it shows the command has created some strange geometry. Seems to be 2 lines very close together on one edge. I offset about 4 mm (used for generating CNC outlines). I can edit the curve and get rid of it, but I do this a fair bit and I’m also wondering if it’s doing some other slightly weird things as sometimes the CNC paths produced by meshoutline are not the smooth curve you’d expect and they end up causing problems when running the machine.

Is there something wrong with the solid form I’m using and is there any way of avoiding this if so?

Many thanks

Weird Meshoutline.3dm (361.5 KB)

Well, first of all, the name of the command should give you a clue. MeshOutline gives you the outline of a mesh (the render mesh if you haven’t used it on a mesh object), so it will be inherently not smooth - it’s a polyline. You can make the resulting polyline finer by making the mesh finer - either changing the render mesh settings or meshing the object with come custom settings and doing the outline on the mesh.

Since your file doesn’t have any other info than the 3D part, from which viewport are you running MeshOutline and the offset? Top? Don’t forget as well that on complex curves, Offset can produce odd results as well.

Thanks for this reply. Sorry I wasn’t clear about the view. It’s the Top view, and I’ve re-done the file with a 4 mm offset on the resultant curve to show what I mean. I can zoom in on the meshoutline curve to see why this happened, but, if possible would like to know if there’s something I need to do to these drawings to avoid it happening…
Thanks again

Weird Meshoutline.3dm (377.6 KB)

Yes, that’s what I saw when I tried from Top previously.

So the problem is in the mesh outline curve - in the file below, the outline curve has a small stacked segment at one area. If you turn on control points, you will see one corner actually has two points instead of one. That in turn causes Offset to go nuts.

I used SimplifyCrv on the mesh outline, but that wasn’t enough to fix it, I actually had to go in and manually remove one knot from two locations… Then it was OK.

I don’t know how to make these things predictable with MeshOutline. My suggestion in any case would be to use Silhouette instead, Flatten the result to the Top CPlane with ProjectToCPlane, then select the silhouette result and use CurveBoolean>DeleteInput=All and click outside the figure somewhere. This will give you an outline, but it will be real NURBS curves that are accurate, not a polyline approximation based on a mesh. The offset on the result in this case works fine. But as Offset can be unpredictable on very complex curves, you might still run into problems here and there.

Weird Meshoutline-Fix3dm.3dm (3.3 MB)

That is brilliant. I do this a lot and can cope with the odd problem but this one was doing it on many of the similar shapes I had.

Will change the technique to this from now on.

Many thanks for your knowledge and willingness to help!