Meshes are wrong placed inside a block


#1

Hi everyone

I’ve already posted this question here Meshes are wrong placed in block that has big base point
I was recommended to create a new post in the Serengeti category and include a 3dm file with my objects.

The key point is that after block creating meshes are wrong placed. I was able reproduce this behavior on Rhino 6 WIP:

Also this is the file with the objects wrong_placed_meshes.3dm (1.3 MB)


(Wim Dekeyser) #2

This appears to depend on where you place the base point. I tried placing the base point both at world 0 and snapped to one of the boxes and then it works fine. When you just pick a point in space, as you do in that clip, then it doesn’t work. Your geometry is far from the origin and the distance to the base point probably gets very large. @stevebaer, is this a display issue that you could look into?

Note that if you pick a shaded display mode, you will be able to see the mesh as well - but it still doesn’t show selected when you select the block.


(Steve Baer) #3

I created a bug report for this at
https://mcneel.myjetbrains.com/youtrack/issue/RH-38742

I haven’t investigated yet, but I’m pretty sure this is another far from origin case that needs to be tuned up.