Mesh of 100% quads?

mesh
unhandled

#1

When converting a NURBS to a mesh, one gets a mixture of quads and triangles. Is there any means of getting instead only quads and no triangles at all? Whatever loss of accuracy might thereby result would be quite acceptable.

Why such a thing? Because I would like to employ Rhino to create also virtual objects for 3D scene generating programs like DAZ 3D, Blender, et all. Those rendering engines are able to subdivide only quads.


#2

you can start with these settings, they work well for simple shapes like cubes or like shown below. you will get some triangles with more complex shapes.

you can play with the minimum maximum edge length to “resize” the mesh but keeping them equal might probably yield the best results.

04

in vip 6 this issue has been targeted, its not completed though and the progress has stagnated for now, but from what i read its pretty neat already, just try for yourself see link below


#3

I will give that a try. Thank you very much. I’m very happy using Rhino 5 for everything else, and was very much hoping for a chance to employ the tool that I know for the 3D art hobby sideline. So thanks again.


#4

@Aplonis If the QuadMesh command is not working for you, can run it through open source Instant Meshes.

http://igl.ethz.ch/projects/instant-meshes/

@DavidEranen
"Since version 10.2, Modo uses the Instant Meshes algorithm to implement its automatic retopology feature."



(Gustavo Fontana) #5

This looks amazing. If it’s open source, could someone turn in into a Rhino plugin?


#6

Its good, and with some additional development it could be amazing. I just realized there is a version from July of this year; I have not used that yet so my comments are based on the version from late 2016.

It possible to guide the quad flow manually if desired, although the default settings work fairly well. There is a setting to preserve sharp edges which is a must for CAD meshes. Unfortunately there are consistently divits or chips missing from sharp edges. Although increasing the resolution helps this to some extent, it does not eliminate them.

I have found with finely detailed objects that its not possible to get the resolution high enough to reproduce the level of detail in the original object.

EDIT I did just test the latest version from July and it seems more stable with higher resolutions than the previous. There is still some chipping on hard edges, or edges where the radius is smaller than the target resolution. This is due to the flow not being precisely aligned to the edge. I think if I had more than 17Gb of RAM a higher resolution might give a useable result.


#7

Let’s hope one way or another.…(channeling Blondie)

Effective quads needs/should be part of Rhino, and if this is avaible to leverage, and nothing better is being hidden under glass, seems a no brainer. The current quadmesh early prototype command has been dog meat in my tests.

Instant Meshes has worked quite well for me in moving Grasshopper generated mesh data to Fusion Sculpt (t-spline) through successful conversion to Model (solid).

ReMake worked well to, and it even has a specific Fusion360 preset, but it will cost you. If the Instant Meshes algorithm is in fact freely available, one could assume AD has/will suck it up, unless they have deemed an alternative superior. (whatever is in ReMake)