Mesh .obj export settings for other applications

I don’t use any of the mesh functions within Rhino, but I have some .obj files exported from Maya and I need to edit, save back out as .obj and then open in Sculptris (a free app from Z Brush). The files open up nicely in both Rhino and Sculptris:

In Rhino, I’m only deleting a couple of objects that I can’t do in Sculptris and then saving it right back out. In this process, something happens to the .obj file and it looks like multiple objects drop out when the Rhino export is opened in Sculptris:

I think I heard that Rhino won’t export a bad mesh, but according to Rhino they are all good. If I import the Rhino object file back into Rhino, everything is there like it’s supposed to be. Like I said, I don’t work with meshes, so it might be something painfully simple that I’m not aware of.
Here is the original object file in a Rhino file:
FileInRhino.3dm (2.2 MB)
Thanks for any help or ideas.

1 Like

Those are reversed face normals. Sculptris culls the backfaces (makes them transparent). Looks like after Rhino your mesh gets mixed up badly. What exactly did you do?

Here is a fixed OBJ (Blender): (808.8 KB)

I simply opened the file, deleted a couple of objects and then exported it back out. Blender was actually my work around, if I simply imported and then exported out of Blender, they worked fine in Sculptris. What is it in Rhino or what am I doing that messes things up?

Yep, that’s a bug. I unloded the export_OBJ.rhp, and loaded the old one from V4 RhinoLabs ( Works like charm.

Can you post a screen grab of your OBJ export settings?




Here are my normal settings, but in trying to get things to work, I used just about every combination of the settings, possible. I thought the issue might be there, so I tried them all, or close to it.

I think these should be close to the Rhino default, if there is such a thing, because I never really use .obj export.

Might this be an export settings issue or is it a bug as suggested by @0netech?