Mesh broken when changing unit

Hi, I am struggling with unit change when making shell mesh.
When I change unit from “m” to “mm” with setting component, the mesh is broken. Model info says, “Mesh face 4: area smaller than limit_area. Will be removed, …”.

When I make mesh with donuts ring as pics with “m” unit, the mesh is renewed when changing its diameter. However, when I do that with “mm” unit, the mesh is broken.

I have tried two methods by referring past threads.
I read this thread and made LDist smaller by 10^(-6) from 10^(-3) as “m” is 1000 times larger than “mm”.

I also checked shell thickness and changed from 1cm to 0.001cm but it is still broken.

Circle_v2.ghx (485.1 KB)

Is there any way to make mesh with “mm” unit?

Thank you in advance,
YWas



Hello @YWas,
thanks for your bug report!
I will check this asap.
– Clemens

Hi @cp1
Thank you for checking.
Looking forward being fixed.

Hi @YWas,

in Karamba3D the snapping distance LDist needs to be set at the component where the elements get created (MeshToshell, LinetToBeam,…) and where the model gets assembled. See here:
Circle_v2_cp.ghx (479.2 KB). Then it works.

The unit selected at the ‘Settings’-component applies to the input of geometry objects only, not to the length units at the component inputs. For the latter one can specify “CustomUnits”.

– Clemens

1 Like

Hi @cp1
Thank you for your support.

the snapping distance LDist needs to be set at the component where the elements get created (MeshToshell, LinetToBeam,…) and where the model gets assembled.

I understood and was able to run without error! I really like the concept of Karamba3D to give a use experience that goes beyond the boundaries of CAE.

Many thanks,
YWas