Measurements on Rhino 7

On Rhino 7, when I take a measurement just to see how long or wide…etc, I cannot delete it, I must type 'Control Z" to get it off. This didn’t happen on 5 or 6. Can somebody tell me if there is a setting for that?

Hi Marcel - I take it you mean you use a dimension for this? And, you cannot delete the dimension?
(Also try Distance and BoundingBox > Output=None for this information)


Hi Pascal
I am not sure what you mean! Where is "Distance and Bounding Box? I know Bounding Box in “Transform” but what has that to do with annotations of measures?

Distance is a command which measures the distance between two points and reports the total distance, and the distance components in the x, y and z directions on the command line…

BoundingBox is a command which creates a bounding box around a selected object or selected objects. The command has options for the orientation of the box and whether the box is retained. The dimentions of the box and the minimum and maximum x, y and z values of the box are reported on the command line.

You may also find Length and Angle useful.
Rhinoceros Help
Rhinoceros Help

Post a .3dm file with an example of a dimension you cannot delete. You can upload a file by dragging it to where your type a post, or by clicking on the vertical arrow icon above where you type a post.

No deleting of measurements.3dm (39.3 KB)
Hi David here it is above.

I opened the file in Version 7 SR7
(7.7.21131.13001, 2021-05-11)
Select a dimension by clicking on it.
Delete key and the dimension is deleted.

Do you have difficulty deleting other types of objects?
What is your prefered method for deleting objects?

No I don’t have any problem deleting other objects, only the dimensions is a problem, I usually press “Delete” button.
I have to say I have no problem with V6 or V5 !
Very bizarre!

Hi Marcel - do you have History Locking on and does the History command show that annotation history is enabled (default)? It seems like maybe something in that area has got its wires crossed - try HistoryPurge on one of the dimensions - does that allow it to be deleted?


Pascal ! you’re a genius!
Yes I unlock the history and it works now. SOlved. I will click on solved. Thanks