Mcneel's license server could not be reached

I am having issues connecting with Rhino’s Cloud License Server. I have allowed Rhino through the Windows Firewall but that did not help the issue. I get this anytime I try to open Rhino. I have no problem logging in to Rhino Accounts and can see all of the available licenses. Here is the error message I am receiving. Thanks for any help.

image

What specifically were you trying to do when you got the error?

For Cloud Zoo licensing, Rhino.exe must be able to contact:

If you were trying to Validate a standalone license when you got the error, see if you can get to https://api.mcneel.com.
If you can, you will see a message that says,

For Robots Only

This web site is to be used by programs and robots. There’s nothing interesting here for humans.

I was just trying to open Rhino using cloud licensing. It prompts me to sign in to the accounts.rhino3d.com, which I can do successfully. I get to the screen that says that you can return to Rhino and close this screen. When I go back to Rhino I see the above error message. I have tried logging out of my account, I have no other internet connection issues, have tried uninstalling and reinstalling Rhino 6 to no success. Thanks.

Hi Charlie - you could try disabling the firewall to see if that changes anything.
Alternatively, a tool like https://www.testports.com/ should be able to test the connection for you. Remove the https:// parts of the urls that John posted above:

image

Should give you: \color{green}Port: \color{green}443 \color{green}on \color{green}host \color{green}cloudzoo.rhino3d.com \color{green}is \color{green}Open
-wim

1 Like

Wim, thank you. I have tried disabling the firewall and connecting with no success. I tested both URL and ports and they are both open. Thanks for the suggestions.

Thanks for trying. Hopefully @aj1 and/or @brian will be able to get back with better suggestions when the West Coast wakes up in a while.
-wim

@charlie.foss do you have the latest service release for Rhino 6 installed? It looks to me like a bug we fixed a while ago - where Rhino was using an insecure version of TLS by default. Some installations of Windows rightly deny use of the older insecure TLS 1.0 protocol. I believe Rhino 6.14 and newer use a more modern version of TLS that should get past this restriction.

@brian, I have version 6.16 installed.

@brian I just tried to use a standalone license just so that I could keep working and it said that the validation server could not connect. I am able to connect to api.mcneel.com via my web browser. Not sure if this is related but it seems to be.

Hi Charlie,

This is confusing for sure. I’m afraid this is almost certainly due to something on your end; we’re getting thousands of hits per hour on both of those servers right now. If you do the following, you’ll be able to validate your standalone license:

  1. Close Rhino
  2. Disable your network connections
  3. Start Rhino
  4. Begin the license validation process. Follow the steps until you are asked to validate offline
  5. Reconnect your network
  6. Follow the instructions to validate offline from our web site

Does this work?