Materials Panel 'stuck' - will not return to materials list

Hi there,
My materials panel is ‘stuck’ on a random individual material. The drop-down menu opens, but clicking on ‘list’ ‘tree’ or ‘grid’ does not bring back the materials list. Other aspects of the drop down still work, like ‘import from library’, but I am unable to return to the grid view where all my materials are stored.

This means, there’s no longer a way to right click on the material and apply it to any objects. (and… of course I am working the weekend making renderings for a presentation tomorrow!)

So far, I’ve tried:
-closing and reopening the Materials Panel (and all other Panels)
-restarting the file
-restarting Rhino (and updating)
-restarting the computer
-resetting my preferences

… and I’m not sure what else to try (or am I missing something really basic about the UI? I’m not new to Rhino, but I don’t render very often and this is my first time applying materials in V7)

I’m not using any plugins.
Mac OS 10.14.6

Rhino 7 SR9 2021-8-10 (Rhino 7, 7.9.21222.15002, Git hash:master @ 190335c3fb65efe86c302714a8959a7dadfe667b)
License type: Commercial, build 2021-08-10
License details: Cloud Zoo

Apple Intel 64-bit macOS Version 10.14.6 (Build 18G9216) (Physical RAM: 32Gb)
Mac Model Identifier: iMac19,1
Language: en-US (MacOS default)

AMD Radeon Pro 575X OpenGL Engine (OpenGL ver:4.1 ATI-2.11.25)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB
Graphics: Radeon Pro 575X
Displays: iMac (217dpi 2x), DELL P2417H (93dpi 1x)

Graphics processors
Radeon Pro 575X (4 GB)
iMac (2560 x 1440)
DELL P2417H (1920 x 1080 @ 60 Hz)

USB devices
Western Digital: My Book 25EE
USB Device : USB 2.0 Hub
Apple Inc.: FaceTime HD Camera (Built-in)
VIA Technologies Inc. : USB 2.0 BILLBOARD

Bluetooth devices
Broadcom: Logitech V470 Cordless Laser Mouse
Broadcom: Magic Keyboard with Numeric Keypad

Third party kernel extensions
com.splashtop.SplashtopSoundDriver (1.0.1) 3B062661-16B4-332C-AFEC-ADAA59069406 (45.3.0) AF401CCC-18F9-3887-8C5A-AE4897C63EA0

Third party plugins

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
/Applications/Rhino “Snapshots” 7.9.21222.1002
/Applications/Rhino “PanelingTools” 7.9.21222.1002
/Applications/Rhino “AnimationTools” 7.9.21222.1002
/Applications/Rhino “Renderer Development Kit” 7.9.21222.1002
/Applications/Rhino “Displacement” 7.9.21222.1002
/Applications/Rhino “Legacy Rhino Render” 7.9.21222.1002
/Applications/Rhino “Commands” 7.9.21222.15002
/Applications/Rhino “Import_OBJ” 7.9.21222.15002
/Applications/Rhino “export_xaml” 7.9.21222.15002
/Applications/Rhino “QuadRemesh” 7.9.21222.15002
/Applications/Rhino “export_OBJ” 7.9.21222.15002
/Applications/Rhino “RDK_EtoUI” 7.9.21222.15002
/Applications/Rhino “Export SVG” 7.9.21222.15002
/Applications/Rhino “MeshCommands” 7.9.21222.15002
/Applications/Rhino “Export_DAE” 7.9.21222.15002
/Applications/Rhino “PDF Export” 7.9.21222.15002
/Applications/Rhino “IGES Export Plug-in” 7.9.21222.15002
/Applications/Rhino “Import_SVG” 7.9.21222.15002
/Applications/Rhino “BlockEdit” 7.9.21222.15002
/Applications/Rhino “Export_AMF” 7.9.21222.15002
/Applications/Rhino “Rhino Render” 7.9.21222.15002
/Applications/Rhino “Import_DST” 7.9.21222.15002
/Applications/Rhino “PLY - Polygon File Format Export” 7.9.21222.15002
/Applications/Rhino “Import_AMF” 7.9.21222.15002
/Applications/Rhino “RhinoCycles” 7.9.21222.15002
/Applications/Rhino “IronPython” 7.9.21222.15002
/Applications/Rhino “Grasshopper” 7.9.21222.15002

Whoops, forgot my screenshots

I’m not sure that this will help, but something to try.

Move your mouse pointer to the dot, the pointer should change to a horizontal line with a downward pointing arrow below it. Click the mouse and drag down.


thanks for your response- I had done that too- just blank!
however I restarted everything again… and the materials list is back. Things are running extremely slow and buggy- material previews not showing up in their preview squares, wheel of doom, takes minutes for commands to apply. So I’m wondering what else is going on with this file or my particular software combo.

Hi Laura - does this messiness show with any file or just one, or?


Just this file- but it’s the largest I’ve worked on in R7 on this machine. I realized I’d copied/ pasted a bunch of geometry instead of blocks, and of course cleaning that up helped a lot- but things are still acting funny. The Materials Edit panel, for example, only loads the preview image (kinda) and none of the adjustable features show up- it’s just blank where they usually appear. I’m going to max out the RAM on this computer this week; hoping that will help for future projects. I’m curious what other hardware or system setup recommendations people might have to optimize for rendering.

Hi Laura - can you export an object that uses ‘paint 2’ to an new file and have that work as expected?


Hey, an update, hoping someone can offer some tricks.

The issues I’m having are basically extreme bogging down with almost every aspect of this file.

@pascal - It didn’t matter which material or object I selected, the same thing would happen (they were all simple 2D surfaces) It’s not only the materials panel- it’s zooming in and out of the view, dragging, scaling… any basic operation is just wheel of doom for at least a few seconds and often over a minute. It’s of course worse in ‘render’ view, but still not great in Wireframe. (I have never touched Raytrace!)

Last night, I maxxed out the RAM on my machine (from 32GB to 128) and… same problem.

I am wondering if something in the file might be corrupt, and if there’s a way to check.
I tried opening the site plan vectors the architect shared with me in an isolated file; I used their geometry as a layout for my additions. The isolated vector geometry is also extremely s l o w and boggy, with no 3D shapes. Unfortunately I can’t share it here b/c it’s proprietary, but I’m wondering if anyone has pointers for how to figure out is something is ‘broken’ in the math of a file.

Hi Laura - with no layers or objects locked and no selection, please run the SelCrv command - what number is reported at the command line? ( “x curves added to the selection”)


47,133 curves

Hm, and if you hide those, do things improve?