Is there a way to disable the gloss effect to objects?


#1

When I create a material that has a gloss effect and apply the material to objects the objects becomes glossy, is there a way to disable it in display properties?


(John Brock) #2

If you change V6 Shaded display to use “default lighting”, you might get the flat, plain effect I think you’re describing.


(Pascal Golay) #3

Hello- if you are using the Rendered display mode, it will show the gloss that is set in the material- is that what you are asking about? That is what materials and rendered modes are for… but if you are asking about the glossy, slightly reflective effect in the shaded mode, you can modify that by removing the environment map in the shaded mode settings -

-Pascal


#4

See picture for problem. I typically like to work in a custom mode that shows the rendered materials. Simply, let’s say I am doing a hardwood floor and I want to create a material that has a texture of hardwood floor with some gloss so that when I click render my render shows up with the gloss. Is all great and good in concept to show the gloss in the display mode, but I get this terrible distortion when I move the camera, the area exposed to the lighting camera is overexposed and the other area is the opposite. Is very disturbing to keep working as I navigate around the model.

Especially when I want to capture the screen and then do an overlay in Photoshop with my final render, the overexposed gloss just gets crazy messy. I know a way to solve this is, by removing the gloss when I create my material, then keep working, but then I have to go back and forth to add it and take it out.



#5

Any updated on ETA to fix this problem is crazy wacky, this gloss thing.

Also if I have several objects that have a specific material and I want to change the gloss it takes a while to update the scene, depends on the amount of geometry, the more geometry, the more crazy slow it takes to update, I am assuming is trying to do the gloss light effect on every single piece of geometry. slows down things a lotttttt.


(Pascal Golay) #6

Hi Pablo - can you please export your custom display mode from Options > Display modes page and post it here?

thanks,

-Pascal


#7

Here are my custom settings

Thanks!Z Pablo Shaded.ini (148.8 KB)


(Pascal Golay) #8

Hi Pablo - it looks like you exported Wireframe - can you make sure you have your custom mode selected in the list and Export again?

-Pascal


(Nathan 'jesterKing' Letwory) #9

I actually see also blowout in Rendered mode when setting glossy of a simple Custom material to 1% - only a simple bitmap texture added to the color channel, further default Custom material.

What you see here is the glossiness with the lowest sharpness possible. You probably should use a less low value, like maybe 10%

Upper viewport is your custom display mode, lower viewport is Rendered with default settings.

Edit: as you can see lower values make the glossy highlight bigger, since bigger value means harder = smaller highlights.