Material Mapping on Pipe/Cylinder

render
texturemapping
unhandled

(Josh) #1

Hello,

I’m hoping this is a simply fix, and possible in Rhino for Mac!

I am wanting to add a timber render finish to a pipe (as a steam bent piece of timber would be), this means the grain should follow the pipe/polysurface not cut through it. Is there a way to do this? I’ve had a play with ‘applycustommapping’ but its not handling it correctly. Maybe I produced the component wrong, but I can’t think of a better way to do it.

Please see attached a screen grab.


#2

It is hard to see how your material maps , but just doing a quick test here is a screenshot & file.

You may have to separate the top pipe and play with material to line up correct.

«Randy

render test.3dm (2.5 MB)


(Josh) #3

Hi Randy,

Thanks for your reply. I’m getting 3 sections correct but it seems to rotate the corners/bends. Any idea how I can get it to be one continuous piece?

Thanks

Test Leg Render.3dm (2.5 MB)


(Pascal Golay) #4

Hi Josh - use the ‘FitRail’ option in Sweep1 or Pipe - does that do it?

-Pascal


(Josh) #5

Hi Pascal,

Yes that does slight fix it, the grain now looks quite stretched round the bend (with both Sweep1 and Pipe).

Also when I render the Sweep1 component I get odd colourful pixelation (see image), any ideas?