Make2D macro suddenly stopped working

I use a macro to cut and paste my 2Ddrawing to a layout tab (Named “RIT”) .

! _-Make2d Pause Layout=View Properties=FromInputObjects CreateHiddenLines=No ShowTangents=Yes CreateSceneSilhouette=No CreateClippingPlaneIntersections=Yes ShowViewRectangle=No GroupOutput=Yes LayerName=Layer RIT::Make2D
_Pause _SelNone _SelLast _Group _Cut _-SetActiveViewport RIT
_Paste _Move 0

I used this since Rhino6 and it has worked without problem since recently. The macro ends itself after “RIT” and the last commands “_Paste _Move 0” doesnt appear in the command bar. It seems like all ongoing commands ends automatically when you change to layout. Is this some service release issue?

Hej Fredrik -
I see that behavior here as well.

Just to make sure, did this work on Rhino 7 at some point and only recently stop working or is this the first time you try this on Rhino 7?

Hi Wim

I have been using it in R7 since it was released, i believe it stop working 1-2 months ago…

Hi Fredrik - here, your macro needs an Enter to complete

... GroupOutput=Yes LayerName=Layer RIT::Make2D _ENTER...

But it does work if there is a viewport named RIT.


Thanks Pascal! It worked! But still strange that the macro worked without a “Enter” for som years…

Is it possible you assumed the user would hit Enter if the settings at the command line looked correct?


Iam not sure what you mean but I have been using this macro the same way all the time but suddenly the macro ended after “RIT” with only a empty command line. An Enter would only repeted the last command.