Make 2d issue

My make2D command in Rhino is not working as it should. It was working perfectly fine up until today.

That’s what I have been doing to create my MAKE2D
I click and drag to create a viewport> set dimension in properties. sel visible > selects what’s in my created viewport> while still selected, I type make2D

When I check the make 2D I find out that it has gone beyond the viewport.

I have attached a screenshot of how make2d Is not sticking to the viewport boundary. I also attached one that I did a day before,You can see the rectangular boundary that make2d produced, it used to crop what’s not in the viewport, but not anymore.

Hope someone can help me out. thank you

can you share a file a nd steps to reproduce?

also please run the systeminfo command in rhino and post the results so we can see if there are any issues with your machine.

Hi @rzeneldin

I was able to reproduce the problem. Here is what I found.

Make2D creates the Drawings from the current ActiveViewport.

So, if you select the objects from the larger viewport, drawings are created with ‘that’ viewport settings. Alternatively, if you select the objects and run the command from you Floating Viewport, you should get what you’re looking for. Let me know if this works for you.

~ ~ ~ ~ ~ ~ ~ ~
Kaushik LS
Chennai, IN

Hi Kaushik,
I have been selecting the objects in the active viewport> while still selected, I type Make2D. and the Make2D command seems to draw the same existing angle in my viewport, but the only thing it’s not cropping as to what is there in the active viewport, it goes to draw the whole model

Kind regards

Could you post a the file?