Make ground plane not reflect environment?


#1

I am using Rhino Interior as environment in the Environments panel.

Is there a simple way to make the ground plane material reflect objects, but not the environment?

I guess, one way to achieve this is to clear the Environments panel, then assign Rhino Interior to all reflective materials except the ground plane. Naturally, this approach means more work, and it is error prone: Every time I add a reflective material, I have to remember to assign Rhino Interior as environment.

Update: Possibly I can assign an solid color black image as environment to the ground plane, to override the global environment. Something to try tomorrow…


#2

You can override the environment for the ground plane, that should do it. If using Brazil you can use Reflection Decay to have the reflectivity ‘fade out.’


#3

But how do I override the environment?

I now tried: When I specify an environment for the ground plane or the ground plane’s material, then that environment get’s add to the environment that I set in the Environments panel. I.e. the ground plane reflects both environments.

By the way, I am using Rhino’s built in renderer.


(Brian James) #4

You’ll need an environment override channel in the material assigned and the default Rhino Render just doesn’t have the feature set to do this. Brazil for Rhino can do it with an option in the Brazil Advanced Material as shown here…

This allows objects to be reflected but not the environment.


#5

Thanks for clarification, Brian!