MAKE 2D of clipping plane

Hello,

I am trying to produce a perspective section using clipping plane but when I do ‘make 2d’ the solids that are cut aren’t filled. It displays the interior of each cut object.
I changed the tolerance of my model to 0,1.

Does anyone know how to fix this, it would save me so much time :slight_smile:

there is an older topic about this:

you may want to post your file ?

if you want a fast result, you may want to use layouts:
https://wiki.mcneel.com/rhino/layouts5

kind regards -tom

Hi Tom,

Thank you for your answer. I can’t upload my file it’s too heavy.

I am not sure if it’s a problem of settings in my rhino or just with make 2d in general.
I don’t use the layout from rhino, I would like to export it in dxf.

This is indeed an old topic.

https://mcneel.myjetbrains.com/youtrack/issue/RH-14679
https://mcneel.myjetbrains.com/youtrack/issue/RH-33007

I personally lost hope that this will ever be resolved one day…

O… Thanks Jeff. So it’s just not implemented yet… I see.
Do you know a way around this problem maybe with other settings or a grasshopper plug-in?

(1) if you just need a fast solution, use layouts - the details will work with clipping planes applied to.

(2) if it is about a section, you can draw a _line and _project it on your surfaces.
than use _orient3Pt to get it back to WorldXY-Plane.

(3) if you even need more info / details, you can copy your geometry and prepare this for the technical drawing, use a planar Surface to trim away all geometry that should be hidden, than use make2d.

Thank you Tom.

In the end I duplicated my model, created a solid and _boleansplit my model. Works better than clipping plane

Not totally sure, but you might want to have a look at the following plugins:

It is actually a shame that Rhino still requires the user to perform a boolean split of the model in order to generate a realistic drawing… If someone from McNeel is listening, please, fix this. This feature has been requested years ago, and is still open, even tagged as major…

Thank you Jeff,

Yes I totally agree!

Hi - I’ve added this thread to the open feature request RH-33007.
-wim