Make 2D command makes only 2D from layouts and as top view

Hi, I try to make 2D from my model, but nothing happens when I choose some of my model views. When I choose layout views, it makes the 2D drawing but only from a top view and not from the view I have chosen for the layout.

Hi @Alli_Hurmola
could you provide a screencaps, or a little bit more detailed info on what you’re trying to do, and what you end up with? Impossible to help with this amount of info. Kiitos.


Sorry, I forgot to post sceencaps which I took. I hope you can see these.

What I can see from the pics, is that you have the Top view active, and _Make2d gives you the Top view’s curves. So, it seems to work as expected.

The “View” option in _Make2d does not refer to Layout 's “view”, if that’s what you are expecting. It refers to the currently active viewport.

If you want the view that is defined in a Layout’s Detail view, first activate the detail by double clicking it, select objects and then _Make2d.

Thank you for your reply.
Unfortunately, it still doesn’t work for me even though I have the details open and active and would select details there. Also, it doesn’t work even though I would have the top view active and open and I would try to do 2D from the top view.

Hi Alli - Make2D delivers the drawing to the World XY plane unless you choose the CPlane option.


When you say “doesn’t work”, what does that mean?
Gives an error? Does nothing?
Can you record a video of the process?

I’m sure it’s just a small thing that you might be omitting or not noticing…