Make 2d coming out strange

rhino
unhandled

(Nicole27793) #1

My Make2d command isn’t working; its showing random lines that aren’t there and leaving out ones that are. Have tried moving it to 0,0 and it hasn’t corrected it

Need help asap!!


(Fabiano Friedrich) #2

Is it a perspective view you are trying to output?


(Kyle Houchens) #3

@doaa this looks similar to the case we saw recently…any idea here?


(Doaa Alsharif) #4

Hi Nicole,
Can you upload the file to https://www.rhino3d.com/upload
Which version of Rhino are you using?


(Nicole27793) #5

Yes this is perspective view, have tried moving it to the origin. Its a large file but I havent had problems like this before. Using rhino 5
Thanks


(Fabiano Friedrich) #6

Hey @nicole27793
I always had problems with large perspectives on Make2D (since 2008…) and I find that the viewport angle is to blame. I normally model my stuff using a camera Lens Length of 17 (I think the standard is set to 50).

There are two things you can do:

  1. Check the camera lens length (RightClick on viewport >> ViewportProperties) and change it to something a bit more conservative, if you are using a wide lens like myself.
  2. If nothing works I would suggest changing it to an Isometric view (View>>SetView>>Isometric>>…).

Hope this helps.


(Nicole27793) #7

Have tried this today and is still doing the same thing unfortunately any other tips?


(Fabiano Friedrich) #8

Any chance you can share the file?


(Nicole27793) #9

Tried uploading and even in a zip file its too large


(Fabiano Friedrich) #10

https://wetransfer.com/ ??


#11

Any chance the viewport is moved in any way while make2D is running?


(Nicole27793) #12

I leave my computer to do it so there is no chance of the viewport moving, have tried numerous things and still getting the same effect. What email shall I we transfer to?


(Fabiano Friedrich) #13

I think you can post the transfer link here on the post. It will expire automatically in X days. Otherwise send it to tzeroarquitetura at gmail.


(Nicole27793) #14

Thanks


(Fabiano Friedrich) #15

Got your file.
It is really weird. It appears some of the geometries do not render at all.
I’ve tried to explode all objects and tried Perspective mode and Isometric Make2D, but to no avail.

I have saved a mesh with the problem here:
part_Make2D.3dm (5.5 MB)

Maybe someone from McNeel can have a go?