Make 2d not working today

make 2d function is not working on my file but was working perfectly yestersday.
I have tried :

  • changing down the units from cm to m.
  • exporting and saving in another file.
  • just showing a one layer

but lots of lines are dropping off the model when I try to take my iso view (saved view and others).

In need of urgent help if possible.


“Not working” as in unknown command, or no command interface, or no results?
Please be specific.

Also V5 or V6?

@Ned1 Also Category Windows or MAC?

I’m using rhino 6 on mac.
after entering make2d it doesn’t spit out any lines.
The file is a large site model with many buildings, land, etc but it now spits out 1 or two lines of the total thousand i guess.

It could be a few different things:

  • Is the model a long way from the coordinate origin?
  • Is the file tolerance too coarse?
  • You may have limited computer resources to work with.

If you want to stage the file somewhere we can get to it, we can try it here.


1 Like

Hi John, I have uploaded it here. I have been trying to take an iso view of the whole model but I’ve managed to just use the pen display to take some out of it. What I do actually need is the camera view working as would like to use make 2d for some setup camera views inside the model.

Hi - Where’s “here”?

I’ve uploaded it on here but it is cutting out. is there another place to send it?

It keeps dropping out for some reason

Hi - you should be able to just drag and drop a 3dm file from your Finder folder onto a message here. You will see the Uploading message at the bottom and then wait until it gets to 100%.

If the file is too big to be attached here, you can upload it using this form:
Make sure to copy the url of this conversation into the Comments field!

Thanks Wim, I have sent it through the link

Can I check whether you received it?


1 Like

Don’t want to poke the fire too hard but would really love some help if you can

Hi Ned - I am testing it now, it is still churning - but I see that the file units are mm, the scene is over 5,000,000 units in extents and and the tolerance is .001… My guess is those are not making Make2d happy, but it may take a bit of fussing to find the right combination - I’ll let you know what I find.
@Ned1 - here, in V6, with no changes to units or tolerance, it takes a long time but I get, well, more than a couple of lines; if I change the file toilerance to .01 then I get what looks to me like decent results, though it’s hard to tell with such a complex scene - can you try that? Open the file you sent us, and change the file tolerance to .01, select all and Make2d - any better?


Can you please type _Systeminfo into the command line and post the results here. Maybe this will help us understand what’s not going right.

Hi Daniel and Pascal,
Thanks or the reply I didn’t get any notification of the reply but I figured it out and it was because the lines came from auto cad and were not good clean joined closed lines before extrusion and even though the elements extruded it was causing problems when trying to make 2d. I cleaned and deleted a few elements before retrying a few times and it worked.