Make 2D is acting crazy

This has never happened to me before and I’m very curious as to why.

When I Make2D I get a crazy 1 point perspective with lines everywhere. I tried exporting then trying a fresh file but the same thing happens.

Also, when I zoom into the very center of the line work (the little box in the center) I find a crappy looking version of the Make2d.

Hopefully someone has come across this problem before. Any help is appreciated.

What version of Rhino are you using including service release? Can you also post the 3dm?

Hi Brian,
Using: Version 5 SR12 64-bit ( 8/10/2015)

I can’t send the file right now because of an IP issue. I actually tried to recreate the problem with another object but it works fine. I realized the problem only seems to happen when I’m “inside” of the object I’m tying to Make2D with. As soon as I zoom “outside” the object Make2d works fine.

Have you seen this before by chance?

Thanks for the extra info. I have seen this before and it’s been fixed in the v6 WIP as of a year ago. If you are registered on the forum with an email address associated with a v5 license you should see the Serengeti category if you’d like to try the WIP. The download link is in Bob’s welcome message in that category.

Here’s the bug report too which I just double checked to make sure it’s still fixed.

Thanks Brian that information helps. Do you know if grasshopper works with SR6?

Thanks again.

I think you mean the v6 WIP right? Grasshopper is included in the WIP…

Sorry Brian I didn’t realize you had written back. You’re correct, I meant V6.

My main concern is that all the plugins I used with grasshopper (mesh tools, human…etc.) wouldn’t work. I’m not entirely sure how that kind of thing transfers. Sounds like I should be fine.

Thanks again for your help.


One of our goals is to try and keep as many grasshopper components working as possible in V6. If you experience problems with any of them we sure would like to know about it. Thanks