Magic Mouse scrolling stuck with multiple windows in single space


#1

When working in a single Rhino window, the Magic Mouse works conform the settings in the Preference panel.
Since the last update (5.0 WIP (5A783w)), rotating the model with the Magic Mouse in the perspective viewport does not work with multiple Rhino windows open in a single OS X space.
It is hard to reproduce the situation in which it does not function, as some commands/actions seem to resolve the malfunction. Changing spaces and returning to a Rhino window often results in the Magic Mouse rotate not working. Again, it is hard to reproduce the situation in which the malfunction stops, but I would state that the combination one space & two or more rhino windows & using Magic Mouse to rotate results in this malfunction for 80% of the time.
This not only applies to perspective layout rotating, but also to all 2D viewports panning.
Rotating/panning using the trackpad always works, no matter whether Magic Mouse rotating/panning is working or not.


(Dan Belcher) #2

Sounds annoying to me. I’m having difficult time reproducing this in the latest WIP (5A794w). I’ve opened four windows in the same OS X space and have been panning and zooming with my Magic Mouse around four different models for the past 5 minutes. Everything is working fine.

Can you please post your System Information (Rhinoceros > About Rhinoceros > More Info… button > Copy to clipboard) as well as your Magic Mouse settings in Rhino’s Preferences? Perhaps others would have better luck reproducing this than I.

Please post any other steps you find to make this happen repeatedly.


#3

Yes, Rhino is a better program without this bug for sure! Here’s my system info;

Software versions
Rhinoceros version: 5.0 WIP (5A783w)
IronPython version: 5.1.2015.131
Language: en (MacOS default)
OS X version: Version 10.10.3 (Build 14D136)

Plug-ins
None

Third party kernel extensions
com.paceap.kext.pacesupport.snowleopard (5.9)

Hardware information

Computer hardware
Hardware model: MacBookPro11,1
Processor: Intel Core i5-4258U CPU @ 2.40GHz
Memory: 8 GB
Architecture: Intel 64 bit

Video hardware
Graphics: Intel Iris 1536 MB
Memory: 1536 MB
Screen size: 1440 x 900
Displays: Color LCD (256dpi 2x)

USB devices
Apple: Internal Memory Card Reader
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices
Apple: Apple Magic Mouse

OpenGL information

OpenGL software
OpenGL version: 2.1 INTEL-10.6.20
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 0x
Mip map filtering: None
Anisotropic filtering: None


I think I also found a way that ‘ensures’ the bug to occur. Open a single window, then use Cmd+O to open one, or several other, file(s) within the same OS X space. Everything still functions normal until now, but if I use the four finger swipe down (App Exposé) to view all separate Rhino windows in my OS X space and select another, the bug occurs.

Hope this helps!


#4

I can´t reproduce this on 5A794w (10.10.3).


#5

I’ve updated to 5A794w as well, but the bug still occurs.

Software information

Software versions
Rhinoceros version: 5.0 WIP (5A794w)
IronPython version: 5.1.2015.131
Language: en (MacOS default)
OS X version: Version 10.10.3 (Build 14D136)

Plug-ins
None

Third party kernel extensions
com.paceap.kext.pacesupport.snowleopard (5.9)

Hardware information

Computer hardware
Hardware model: MacBookPro11,1
Processor: Intel Core i5-4258U CPU @ 2.40GHz
Memory: 8 GB
Architecture: Intel 64 bit

Video hardware
Graphics: Intel Iris 1536 MB
Memory: 1536 MB
Screen size: 1440 x 900
Displays: Color LCD (256dpi 2x)

USB devices
Apple: Internal Memory Card Reader
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices
Apple: Apple Magic Mouse
Broadcom:

OpenGL information

OpenGL software
OpenGL version: 2.1 INTEL-10.6.20
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 0x
Mip map filtering: None
Anisotropic filtering: None


(Dan Belcher) #6

Thanks for continuing to investigate this. I tried these steps:

  1. Start Rhino WIP (5A794w) on 10.10.3. Open a new modeling window (empty).
  2. Press Command+O to open another (non-empty) model. Scroll, orbit, etc, using my Magic Mouse in all four windows of the non-empty demo. Everything functions normally.
  3. Four-finger swipe (App Exposé) to view both modeling windows.
  4. Selected empty model to bring it to the foreground.
  5. Scroll, orbit, pan, etc using my Magic Mouse…

Everything functions normally. What step am I missing? I want to replicate this…but I may have to chase down the exact machine you have.


(Marlin Prowell) #7

From your system information:

What does this extension do?

Does your problem still occur when you delete this extension?


#8

@marlin It could be a leftover from a render engine that I have tried, but I can not find it in either the /Library/Extensions or /System/Library/Extensions folder. I deleted PACESupport.kext, but hereafter the extension is still listed in the Rhino System Info;

Software versions
Rhinoceros version: 5.0 WIP (5A805w)
IronPython version: 5.1.2015.131
Language: en (MacOS default)
OS X version: Version 10.10.3 (Build 14D136)

Plug-ins
None

Third party kernel extensions
com.paceap.kext.pacesupport.snowleopard (5.9)

Hardware information

Computer hardware
Hardware model: MacBookPro11,1
Processor: Intel Core i5-4258U CPU @ 2.40GHz
Memory: 8 GB
Architecture: Intel 64 bit

Video hardware
Graphics: Intel Iris 1536 MB
Memory: 1536 MB
Screen size: 1440 x 900
Displays: Color LCD (256dpi 2x)

USB devices
Apple: Internal Memory Card Reader
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices
Broadcom:

OpenGL information

OpenGL software
OpenGL version: 2.1 INTEL-10.6.20
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 0x
Mip map filtering: None
Anisotropic filtering: None

@dan Yes, these are the steps that I perform as well. Opening an empty or an existing model in step 1 makes no difference.
The bug still exists in the latest build, 5A805w.


(Marlin Prowell) #9

Look for an extension named pacesupport.snowleopard in your two extensions folders. I’m deducing the file name from this post: http://www.logicprohelp.com/forum/viewtopic.php?f=10&t=84193


#10

The old pace drivers are a known bugaboo, generally.


#11

Yes I guess so, can’t find anything alike in the two extension folders, even after unhiding all files.