Inconsistent zooming in RhinoWIP for Mac


I’m using RhinoWIP for Mac, and having inconsistent zooming behavior with the trackpad and magic mouse. I’m using the scroll to zoom method, scrolling on the magic mouse ‘wheel’ or scrolling up an down on the trackpad. Typically, this works fine, but sometimes it just stops working altogether. Scrolling has no impact on the viewport.

I’ve tried commands like zoom extents or other commands that would ‘reset’ the camera, but those methods don’t change anything.

Restarting the program corrects the problem, but i’d rather avoid doing this.

I’m running el capitan 10.11.3 on (up to date at time of posting) a mid 2012 mackbook pro retina with 8GB ram, 2.4Ghz processor. I’m also running a dual monitor setup, with a slightly order mac cinema display.

Hi Greg - I have not run into this yet myself - did I understand that Zoom Extents does nothing when things get in this state, but that the viewport is not actually frozen - you can do some pannng/zooming, just not what you expect, or is the view in fact completely frozen?


Hey Pascal, thanks for responding!

Sorry for not being more clear. The viewport is not frozen. Other ways of instantiating zoom work - running the zoom extents or zoom select command, holding command and dragging, running the zoom window command, etc.

All zoom, pan, and orbit commands work, but how the zoom command is instantiated is inconsistent. It’s the scroll wheel/scrolling on the trackpad to zoom in and out that periodically stops working.

does that clarify?

Hi Greg - got that, thanks.


Hi Greg-

We will be releasing a new RhinoWIP in the near future that we hope will address some of these issues. I’ll be curious to hear if they do. Let’s circle back around when the RhinoWIP is published and see if your problems are still there.

Hi again Greg-

Please test in the this RhinoWIP (published just now) and see if things are better.


I’m trying it out now, and having a similar problem.

When I open RhinoWIP fresh, I can zoom in and out by scrolling on the magic mouse ‘wheel’ with no problems. At some point(I haven’t been able to distinguish when this happens), I can no longer zoom in and out on the magic mouse scroll wheel.

I’ll pay closer attention and try to diagnose what triggers this condition.

I’ve also noticed that while orbiting with the magic mouse right click + drag, I can still trigger the zoom by scrolling in and out on the magic mouse wheel with my left finger. I can’t tell if this is a feature or a bug. It seems like sometimes you want to be able to zoom and orbit at once, but it often results in viewport jumping and sometimes getting the view all out of whack.

In preferences, I have enable magic mouse gestures checked on, and have “scroll with one finger to pan and rotate views” unchecked.

Odd. These are the settings that I use as well with my Magic Mouse and it seems to work fine. Something else must be going on here. What are your settings like in the main tab of Preferences > Mouse?

Hey Dan. Strange. Here’s screenshots of my mouse preferences:

I’m wondering if it’s a problem with my magic mouse. It’s about 2 years old, so it could be having some problems of it’s own.

Do you ever have the viewport jumping/chopping due to triggering the magic mouse scroll wheel zoom, during an orbit via right click+drag?

Thank you. I have the same settings.

I doubt it. I have heard similar reports from other users. I’d like to better understand what is causing this behavior. What are your System Preferences > Mouse settings? (for comparison purposes).

Do you ever have the viewport jumping/chopping due to triggering the magic mouse scroll wheel zoom, during an orbit via right click+drag?

I don’t see this issue on my computer, but I’m not using Rhino nearly as much as y’all (occupational hazard of typing code). I do hear about this issue, so it’s definitely concerning. I suspect others here have seen this issue as well.

Here’s screenshots of my system preferences > mouse

Dan - if it would be of interest to you, I would do a screenshare of some sort with you, so you can see how some of these things happen. Of course - only if you feel like it would be useful. I just wanna help if I can!

Hi Greg
have you tried with fresh batteries for the magic mouse…?
your screen shot show it is in the red.
with best regards

Hey Akash, yes, mouse batteries were not low at the time of my original post, and I replaces them just now and still have issues.

Thanks for including those settings.

My co-worker @marlin pointed out something that made me think: “Have I trained myself to overcome the ergonomics of this MagicMouse?” Let me quote what he said:

[Marlin] The MagicMouse has terrible two button ergonomics. To right-click using your middle finger, you must make sure your index finger is not resting on the mouse surface when you press with your middle finger, or it will register as a left-click.

I watched my fingers when I used the MagicMouse to zoom, orbit, and pan and - sure enough - I pick up my right-mouse-button finger when I orbit and my left-mouse-finger when I select. I unconsciously do this…I wasn’t aware of it. When I consciously leave both fingers on top and try to zoom and pan at the same time, blam, the zoom jumps around like crazy.

This is not a very good answer. I’m still trying to figure out what would be.