MacRhino Picture Frame files grayed out (always)


#1

I keep forgetting to mention this, but in 5.4 (and all previous versions) my picture frames are always (literally) grayed out after saving my files. The only way the file path is ever “remembered” is if I update each picture manually in the Material/Edit/textures/color/Map File path. This is very time consuming, but when I go through this process the file DOES finally retain the picture frame path location when I reopen the file. Does anyone else have this problem and if so, are your picture frames remembered after doing this? Can McNeel please look into this if others can confirm this? Many thanks!


#2

make sure you have ‘embed bitmap’ selected in the PictureFrame options:


the image should then store itself in the .3dm without needing to link to it.
(or, it works for me at least)


#3

Many thanks Jeff…, but is that a Windows-only option? While Rhino help says there is a “EmbedBitmap” and “AlphaTransparency” option (also useful), I can’t find the Picture Frame options anywhere to select these features. In a 2016 post, I read that this feature wasn’t in MacRhino (yet). Can you direct me to the Picture Frame options window you posted? Thanks!


#4

that’s a screenshot from Rhino for Mac.

i use the popup style command line instead of the default sidebar style so that’s where this dialog is from.

i would assume the same thing should show up in the left sidebar if using the default settings??.. i can try it out in a couple hours to confirm.


#5

hey @Buzzlightyear

i set it up with the command dialog in the left sidebar and when using PictureFrame, the embed bitmap option is still there:

17%20PM


what happens when you run the command?


#6

Hi Jeff - Thanks for your persistence, but I must have set up my layout so that these options aren’t shown for some reason. I maximize my real estate on my 4-view monitor and leave all my tool pallets open on my secondary monitor. (That way I can get to them quickly because I know the arrangement.) I never use the command line, and when I type “PictureFrame” in it I get the same dialog box asking me for a file location. I never get any options dialog box at all. I suppose it’s not the end of the world, but I would like to know how to get the PictureFrame window open that you show. Thanks - BuzzRHINO LAYOUT.zip (963.5 KB)


#7

the options should show up here:

run PictureFrame, the finder like open dialog will appear, choose the image, then the options should show up in the area circled in red.

if that’s not happening for you then i’m at a loss.
??


#8

Yup…, that’s the problem. I’m at a loss too. When I type in PictureFrame, all I get is the standard dialog box asking me for the location of the file I want to place as the image! Oh well, thanks for your perseverance…, at least I’m not losing my mind :wink: Maybe McNeel will look into it. Happy modeling! Buzz


#9

that’s normal… what happens after you’ve chosen the image?

at that point, you should be able to place the image in the model area and ALSO, the dialog should appear on the left side during this stage.


#10

HA!! Right you are Jeff! I never use the command line and access ALL of my tools directly from the tool pallets on my secondary monitor. Sure enough, the dialog appears in the left hand area after selecting my image. Gee…, I wonder what other options I’ve missed by ignoring the Command line area :wink: Just goes to show how “programmed” I am as a die hard Mac Head to ignore text input and rely on graphical icons for all my needs. That’s why I wasted $10k on Maya as my modeling tool, only to hate it and change to MacRhino. Thanks for sticking with me on this. I do wonder why McNeel doesn’t put things like this win their Preferences panel (where they normally would be found in a Mac app). Even after using Rhino for 2+ years, I still get stuck on dumb stuff like this. But the program is still awesome! Thanks again :slight_smile:


#11

haha.

glad you see it now
:smiley:


a lot of options :wink:


#12

Hey Jeff…, I was wondering how you got that PictureFrame dialog box to open in a separate window in your example above (which is the general way the Mac interface works). Is there a way to get ALL of those dialogues to open separately instead of having them buried below the Command line area? Just curious. Thanks!

Buzz


#13

hi Buzz

in the menu up top, go Rhinoceros -> Preferences-> Themes:

select Use command options dialog


the dialog will then pop up when you’re running command and disappear once the command is finished… you can move it around and it will remember its position.

another setting i’ve changed from default in Themes is to remove the Osnap panel from the sidebar.

with the above two changes, if you like, you can then shrink the left sidebar to two icons wide instead of the more blocky arrangement of default… it will look more like this:


#14

Wahoo! Fantastic Jeff - thanks. Just the interface mods I’m looking for. To me, this make the interface much more “Mac like”. I guess it’s a case of the old saying “When all else fails, read the directions”. While I’ve looked closely at the preferences, clearly I’ve missed a lot because I don’t recognize the terminology. And some options aren’t in the Pref’s panel where I would normally expect them. Thanks again for your help (and sorry for the delay in responding - things have been busy ;-)) Buzz