Picture Frame is NOT working


#1

Anyone else having this issue? Since I installed the latest version of Rhino for mac, I tried to use ‘picture frame’, which I always use, but all the .jpg etc files are greyed out… as if the files are no longer good for using with picture frame. Am I missing something? thanks:)

UPDATE: before I wrote this, I searched for ‘picture frame’ and nothing relevant came up, but after I posted it, I see the same exact thing is under mine… how do I delete this now?


PictureFrame Rhino OSX not working -- ugh
(Dale Fugier) #2

#3

Well… as long as I’m here… is there a way to get around this issue? like applying the picture to a texture of something or something like that?


(Dale Fugier) #4

Run the -PictureFrame command (notice the hyphen) and enter the full path to your picture file.


#5

you’re my hero!
I’m always blown away by how smart people are here… wish I had a tiny bit of all that knowledge:)


#6

How do you enter full path of the picture? I tried copying the directory from the Info box, but nothing happens…


(Dale Fugier) #7

You need both the directory and the file name. For example:

/users/dalefugier/pictures/mypic.jpg

– Dale


#8

It worked… and now it’s not working… it’s like the Rhino Gods are doing this and laughing:)
-PictureFrame command no longer works for me:(


#9

if you drop the photo into a simple text editor, it will show you the full path… but you can’t be in Rich Text… you have to be in Plain Text:)
works very well in TextEdit: so when you open up the program, go to format, and select ‘Make Plain Text’ and then drop in your photo.
Hope this helps:)


(Wim Dekeyser) #10

Not on a Mac here…
Can you drag and drop a photo from your file manager (assuming there is such a thing on a Mac :speak_no_evil:) into a Rhino viewport?


#11

Sorry @wim, not possible on a Mac, and the OS X app like “Windows Explorer”, is called “Finder” .
But I can drag & Drop images from Fibder here on Discourse, like so …

You can use the -PictureFrame command (notice the hyphen) …

Then enter the full path to your picture file with file extension

If you make it this far you get this …

Then this …

So what I did yesterday is made a folder on the Desktop and copied all my needed images there then put my path in a TextEdit document for easy copying and pasting…

users/username/Desktop/Folder/image.extension

IHTH «Randy


#12

Is there also something on mac like the windows version rhinoscripts with - (hyphen) dont work if a file / image has a space in it so “users/test name/Desktop/Folder/image.extension” (double quotes) needs to be added to make it work?


#13

It’s not working here either. After running -PictureFrame and pasting the path nothing happens.


#14

If you have not discarded the previous download other than into the waste bin, you can recover it and reinstall it as a second version of Rhino. Just ignore the “later version available” message. It will still be valid until March 15th, so you can make your picture frame in that version into a new .3dm file. After that open the new file and the file you want it to be added to with the current Rhino version, and copy/paste it.
Or just load your existing file with the older Rhino version and get your picture in its frame :smile:

Max.


#15

fwiw… probably the easiest way to get a file’s path in copy/paste form is to drag&drop it into a terminal window.


#16

How about, RMB on the file you want the path, and choose Get Info. You can copy the path from the General tab


#17

not sure why but they changed the way it’s displayed in yosemite… (but still, it doesn’t have the file name in there anyway)


#18

If it ain’t broke, don’t fix it!! Can’t understand why they need to change something that worked fine for many years…


#19

The most odd thing is that it worked just fine that same day on that same new version.
I did the -PictureFrame and it worked.
The next time I opened it up, it was no longer working…
I wonder how that happens…


#20

This kind of works best if no spaces in any names, or it may require lots of editing.

But thanks for some Terminal magic. It gets stored in “the little grey cells”.

The good thing these days is a new WIP is out every week, or so and I always have my last couple versions for situations like this … a bug in a command I use every work session.