Images not showing in MacRhino

Some images imported in Rhino Windows won’t show in MacRhino.
See attached files.

Mac Rhino:

Win Rhino:

Rhino file:
specchio.3dm (1.2 MB)

when you bring in the image, you have to use the Embed Bitmap option if you want the image to save with the .3dm… otherwise, the image will only be visible in rhino if the image remains on the same path…

ie- without Embed Bitmap, i can pictureFrame a .jpg which is on my desktop and it shows up fine in rhino… i can then move that .jpg to ,say, my documents folder and it won’t show up in rhino anymore…

likewise, i can transfer the .jpg and .3dm to another mac and put the .jpg on the desktop and it will show up fine in rhino (the .jpg is on the same path as the original PictureFrame operation)…

-or- i can use the Embed option and open it on any computer without transferring the .jpg or worrying about it’s location

So what about those images that were not embed to begin with? I cannot find a way to embed them after the fact.

Not on my Mac at the moment, but if you type -SaveAs (with dash) you should have a number of command line options, including SaveTextures… You need to say yes (checkmark in the box, I believe)… That should save the bitmap in the file. At least it does under Windows. --Mitch

just tried it and it doesn’t work.

it seems as if the problem might be with the whole -SaveAs command though… i don’t think it’s saving a file anyway so it doesn’t matter what options are ticked.

or, when using the -SaveAs option ‘browse’ and trying to save to a different location, no new file will be created.


@Brandon_Scott if you have to do it anytime soon, probably best to redo the pictureFrame_ing in the file with the embed option checked.