Mac WIP 5A783w - Insert DWG/DXF Files

I’ve not used the Mac Rhino Beta for some time, but it no longer seems possible to insert DWG or DXF files, either embedded or linked. The files are simply greyed out. No matter what version.

Rhino files that already have a block linking to a DWG are retained and still work fine.

Is there another way to go about this now, or has the feature just disappeared for some reason? (It’s still possible to import the files I notice.)



Hi Neil - I have to admit that Insert is not a thing I’ve used much on the Mac side, so I can’t say how it used to be, but I see that at the moment, it only seems to be possible to insert 3dm files… Import seems OK.


it seems the functionality is there, just some criss-crossed wires? (similar anomalies happen with Import depending on how/what you’re trying to import).

using -Insert then a few not so obvious UI choices along the way, you’ll eventually arrive at a DWG Insert dialog (or .obj etc)

it seems not to be a matter of implementing the ability… more about getting the user interface to work right ?

Hi, sorry I’ve not checked back on this for a while.

I’ve looked at this again on the latest 5A855 build, and this still doesn’t appear to work.

While it’s possible to insert a DWG file, I don’t see a way to import it as a referenced block.

This is an essential feature on the PC version for anyone working with drawings which are produced and updated in other CAD programmes.

Jeff, what are these ‘not so obvious UI choices’ you’ve found?

Jeff is correct. You can manage to insert a DWG if you use the dash version of the command and not the dialog. The dialog version must be buggy.

_-Insert (with dash)
Check “File” and set “Link mode” to Link.
Beware, if you have entered an object name in the text box, it can revert to a previous name, so do this last.
Browse to the file, check “Block” and then Done.

You can then update the linked block via the block manager

But the whole procedure is kinda funky/clunky on Mac… And the dialog should just work.


Hmm, that bug is listed as closed/duplicate…

What I see is that the dialog version isn’t working, but the dash version of the command is.


Mitch, the duplicate item is still marked Open.


Where is the duplicate? How do you find it from the closed bug?

Ah, it was not marked ‘All Users’. It is now - you should be able to get there from the closed one - near the strikethrough bug number, just below it, there is a link.


OK, thanks! --M

Hi there,
i just bought the “FINAL” version of rhino for mac and i am not able to “insert” DWG-files yet. I know it worked fine somewhen before and i really wonder why it is not possible anymore. I used this option a lot with DWG and i definitely would like to get this possibility back!!! Maybe i did`t get the point, are there some settings i have to change to get this work again?


It is not fixed yet, apparently -

However, according to my comment in the above bug report, the -dash version of the Insert command does work - or did at the time of the report. No Mac here today to test…