Mac file save behavior drives me crazy

I really don’t get the way this works. I open a file of a student, and it is on their drive (I have a synched copy through OneDrive), so it starts saving things I try, what I don’t want. Do I really need to open and duplicate the file to prevent this? I am used to opening a file and then when there are enough changes, I would save a new version and KEEP the one I opened IN THE STATE I OPENED IT. This seems totally impossible on the Mac.

I think you are correct. That’s just how Mac file saving works.
I’m not aware of anything in Rhino to block this MacOS behavior, other than to remember to Revert when you close it.

But here comes another issue: even though I choose revert, it still saves my changes :man_facepalming:
could that be a OneDrive issue?

Maybe, I don’t know.
I don’t use OneDrive.
I keep my files local and they are backed up using iCloud Drive.

OneDrive is the Microsoft cloud storage tool, right?

1 Like

Sounds to me like standard cloud storage behaviour! If your students share their files via OneDrive and you edit them, the changes will be reflected across the board.

Yes, but Revert will not revert. I was wondering if Rhino could do something about that

Maybe you can fine tune the settings under Rhino>Preferences>Advanced?

Revert not working could have to do with file versioning on OneDrive, which I don’t use?

Same here and I don’t have any issue. If I edit a file and then I decide that I don’t want the changes I just revert and the changes will not affect the file.

Also, if you want to make sure that you don’t want to edit the file, you can click on the title and lock it, if you do any changes to the file a pop up window will appear asking you if want to duplicate the file or keep it locked.


On the rare occasion when I open a file from the Mac that is on a Windows Network drive, I’m warned that the versioning/revert tools are disabled.
For the Mac Revert tools to work, the file needs to live on a supported drive.

1 Like

ok, I don’t get these warnings. But the solution @jespizua posted is perfect