M1X & Monterey

I downloaded the rhino 8 WIP to see if the same model was usable but it had the same issues. Couldn’t even pan around in wireframe mode. But it also looks like the latest WIP hasn’t switched to Metal yet which might solve this problem.

Regardless, waiting for Rhino 8 isn’t a viable option. I hope this is something that will be fixed with an update to Rhino 7. Until then the functionality of rhino on M1 / M1 Pro/Max Macs is severely limited. Maybe it’s also an issue with Monterey — do users on M1 macs running Big Sur have the same issues?

Halp :sob:

A post was split to a new topic: Export issue on macOS Monterey

does testmetal not work?

Technically yes but it doesn’t display anything properly - it adds some extra geometries to certain objects. It seems like it’s still under development based on this thread. That said, I was able to pan around without the crazy lags. But when will this actually be available / released as part of Rhino 8? I assume not for a while.

Can you share your model which adds extra geometries when running on Metal? I’m not aware of this bug and would like to fix it.

Sure - can I send it to you via email? I can’t share it here.

Yes, my email address is steve@mcneel.com

I just tried the “TestMetal” command in Rhino8 WIP and it worked!!

The speed of viewing the model looks great and totally enables me to work on my models. This was a HUGE help and I’m really looking forward to more development on this. Its also great to read around the forum and see that Metal is in the works and Mac support appears to be a continued effort on the Rhino platform… huge relief as our office runs on Mac’s equipped with Rhino.

4 Likes

oh, pity - I just though that would save you the hassle of developing for 2 different APIs and having 2 codebases.
Have my hopes for Direct3d then - I think we would benefit from more modern API (compared to OpenGL).

yes I just tried it on a large model which pretty much impossible to work on before but with “testmetal” activated its super smooth… not all the rendering modes work but its not bad
see here:
https://vimeo.com/647456848

For reference, @vonn 's display issues with TestMetal were related to blocks and improperly handling of the block transforms. This will be fixed in the next Rhino 8 WIP (usually shipped every Tuesday).

Hi Steve, was having performance issue on both Rhino 7 and WIP 8 prior today’s update and still having the same issue.

Model with meshes that runs extremely smooth on windows doesn’t perform well and stutters in both Rhino 7 and latest WIP 8 on M1 Pro Mac.

Navigation is only okay when enabled “testmetal” on WIP 8. Or joining meshes into one.

Please advise.

As far as advice, probably stick with your Windows computers for now if you are having issues.

Metal development is still in an early phase and I would expect performance to improve with time. The initial goal is just to get the screen to display everything correctly using metal; performance optimizations come later. If you can share your model that you are having problems with, we can take a look at it and see if there is anything that can be done.

Just purchased a new MacBook Pro 2021 - operating with Mac OS Monterey 12.0 with the M1 Max chip. I have downloaded and installed both versions Rhino 7 and Rhino 8 WIP. Each time I attempt to open the application, I am immediately prompted with “Rhino quit unexpectedly” - unable to open the application at all. I understand this is an intel based program and I have Rosetta 2 installed. Any ideas?

I answered your duplicate post. I have almost the same setup and was able to install and open. OS Monterey 12.0.1 Pro Chip, not MAX

I’m running Rhino 7 and 8 WIP on an 2021 M1 Pro machine. In the newest build of Rhino 8 WIP I can’t open the display mode settings in the options menu. Anyone else having this issue?

Hi Ben -

Yes, that’s not limited to machines running Apple Silicon. We have it on the list as RH-66462.
Thanks,
-wim

1 Like

RH-66462 is fixed in the latest WIP

1 Like

Hello, I am having similar issues on my MacBook Pro 14" 16Gb Ram M1 Pro Chip. I have tried using metal on WIP which worked for a few seconds and then crashed. It also worked momentarily sometimes, and then slowed down just as much as v7. I deleted it. I have already turned a bunch of layers off, and it is still slow enough to slow me down. Is there anything else that I can do?

Hi Danna -

Not really. Development work around the Metal display pipeline is still very active every single day and there will continue to be improvements and setbacks as this work continues.
-wim