Lofting an arc on grasshopper problem

Hi. this is a very basic question but I couldn’t find a solution. I’m trying to loft curves around an arc and managed last time but now grasshopper seems to be closing the arc into a loop. I tried Loft Options but it doesn’t seem to work. Is there a setting that I am missing?

I didn’t upload the file because it is quite big, but let me know if you would like to see

Could you post at least the GH file ?

It’s a bit messy, but here you go.
230720_ARCH_hp_shell_EM (35.6 KB)

The last loft is the one with the problem.

Thanks so much.

You didn’t post the file corresponding to your screenshot … It seems like a former version.

My bad! Sorry about that. Here you go.

230725_ARCH_hp_shell_EM (38.5 KB)

Your problem comes from the sorting of your section curves.
We can see that the first triangle is at the end of the lofting list, so it generates the “loop” you’re talking about.

1 Like

Hi, yes that is it. I’ve been trying to solve it by merging the lists rather than joining them and flattening them and it worked for almost all but I’m once again having the same issue. How can I reorder the loft list?

“Joining” is useful to join curves, it transforms exploded segments into joined curves. This is not what you need.
“Merging” is closer of what you want. But you don’t control the order of items in the merged list.
You need to use the Insert Items component in order to place the inserted item where you want it to be.
In that case, at the end of the list, or at the index -1 of the original list.

I didn’t mention it, but you also have to deactivate the closed polysurface option in the Loft component…

1 Like