Loft issue in loose style

hello guys i using rhino 7 and when i loft in loose style the surface not smooth and when i use the same curves in rhino 5 i get smooth surface can you help me to solve that .
pictures would explain better than words



What Rebuild options are you using in R5?

same as rhino 7 the curves is same too

Hi @zoghpy-tt can you send the .3dm file so we can investigate?

try the same with “snap to knots = no” in Rhino 7

my guess:
the alignment of the curves in Rhino 5 is by shortest Distance by default.
the alignment in Rhino 7 is closest Knot… (if option above is on)


this is the files from rhino 7 and 5

loft 5.3dm (302.7 KB)
loft 7.3dm (163.6 KB)

its off in both

snap to knots is yes / on in your screenshot !!!

dear @zoghpy-tt
I think you re expecting to much from this playful mixture of curves / curve-types.

to get a somehow predictable / consistent result i would set the
middel / bottom, of each curve to the desired position.
then _rebuild (10,3) the curves
then _loft

if you compare rh5 and rh7 result make sure the Alignment is the same, both times you run the command. ( you might want to draw it as additional curve ).
My guess - as soon as one start-endpoint-corner of the inital curve is used as alignment-position you get the unwanted crease.

But as mentioned above - having nicer curves will save you a lot of struggle.

yes i know i turned off and got the same results

the curves is for surface to use in powermill to decide tool direction so it must be like that.
and the issue happens with polyline curves only i ask since it work fine with no issue in rhino 5

running the
the v5 version is periodic in v direction
the v7 is only closed, but not periodic in v direction version isn’t.

looks like
do only effect the u-direction

we miss a _makePeriodicUV and a _makeNonPeriodicUV

a simple workaround:
_loft (not periodic in v-direction)
_dir → swapUV
_makePeriodic (in the “new” u-direction, the initial v-direction)

does this help ?

yes it worked thank you mate, but is there fix to make loft periodic in v-direction directly in rh7 ?

Make sure that you are running the latest service release. That “Rhinoceros 7 Corporate” version has some nasty, old bugs in it :rofl:

1 Like