Always problems with lofting curves

hello, i’ve searched the forum but couldn’t find this issue which has been bugging me since years, i’ve gotten used to it and found workarounds but still i would like to understand wether this is normal behaviour, a bug or my stupidity/ignorance …

when i loft more than 2 curves most of the times there will be a problem of ‘curve order’, no matter in which sequence i select the curves rhinos loft function will reorder them.

Look at this for example … to be sure they will align i rebuilt all the curves and set their curve seam to the same location:

… when i lofted straight after that the loft aligned ok but the curve seams of two of the curves have moved again and i have to set them through the loft interface:

i then moved around some of the curves a tiny bit (only moved in 2d, no changes on the curve structure) and when i try to loft again i’m back to square one (also note that now another curve has its seam moved):

ihave mot found any way to solve this ‘order’ problem … sometimes the rebuild curve trick works but often it doesn’t and then i have to loft only part of the curves in batches, here for example i could loft the outer 3 curves and then the inner two curves and join the resulting surfaces somehow … but of course this doesn’t produce the same result as lofting all curves at once…

what is going on ?


are you on Mac ? Please apply a category to your post.

Under Windows, you usually can control the loft ordering by first starting the _Loft command and then selecting the curves in the desired order. For closed curves, Rhino cooks up some adjustable seam points, if they are not as desired, click on Natural in the commandline, over here this sets the seam points to the curve start points and the seam arrows to the curve directions. Any better ?


1 Like

hey thx Clement, the reason i didn’t apply a category is that i was experiencing this bth on windows and on mac.

but you demystified it for me :slight_smile: the problem was that i was selecting the curves BEFORE applying the loft command and that produces the mentioned random results … i i run the loft command and then select the curve it works.

thx so much for clearing this up … which i had asked this sooner :slight_smile:

Hi Chris - the problem occurs usually, when there is not a clear ordering of the curves in space and curves are pre-selected - the automatic curve sorter can get confused. It pretty much always does is the curves all meet at one end for instance, but it can happen in other cases - it’s hard to see in your image how the curves are arranged at the far end.


Great question. I have also experienced this behavior and was curious.

Not sure if you’ve tried the plugin DevSrf but it’s similar to loft, and I think behaves the same as you described - select order is important.

DevSrf uses only two rails. Order of selection is not important.

Right you are. I thought I was getting different results by selecting curves before calling DevSrf, rather than using ‘Pick Rails’ to select them in a specific order. Can’t reproduce it now. I should refrain from commenting until I know what I’m talking about :slight_smile: