Locally transform multiple meshes

Hi Everyone!

I cant seem to find a way to transform multiple meshes locally, everything I tried only transforms the whole thing by the worlds axis. If anyone knows a sollution for this, I would be very thankful!


You’ll have to deconstruct the mesh, figure out which vertices you want to change, transform only those vertices, then recreate the mesh. Grasshopper does not allow for mesh-sub-selections.

Alternatively you can create a set of anchor points + motion vectors (one for each vertex you want to change) and use the Point Deform component.

Hi David, thank you very much for your reply. I’ll try to describe my problem.
I’ve got aprox. 300 objects, which all need to move 0.2 units in their own local y-axis.
I can do this by hand by selecting the gumball, set it to allign to object, then press the y-axis arrow and type in 0.2. But this will take a loooong time :slight_smile: I was wondering if there is any way to do them all at once.

Thanks again for your time.

hi, You should really upload your file or part of it
(I would suggest going through Michael’s link thoroughly, it would help you get helped)
I once had a similar problem and didn’t get to any solution like the ‘local coordinates’ in 3Ds max, it’s a different philosophy I guess. One way -if the objects are similar- is to extract vectors using the vertexes of their geometry.

here is an example:
local coordinates.gh (24.2 KB)

I thought you only wanted part of each object moved. But you want to move each object as a whole, just each object differently. You just have to make a different transform for each object. Basically, make it work for one mesh, and then plug in your entire list of meshes and if all goes well it just works. If not, maybe you’ll need some additional data matching logic.

Sorry about not providing a lot visual information about my project, I signed an NDA so I need to be very careful.
Thank you very much for setting that up for me Aris, really appreciated. I copied the nodes into my scene and plugged the Geo node which contains the objects into it. Can you please tell me what I am doing wrong?

[EDIT] What you see are a few small diamonds, they are all lined up in a certain curve. I need to offset them al in a little in their local blue arrow gumball axis. I need to do this because they are intersecting a little with the ring underneath, causing weird refraction artifacts in the render.
Many thanks!!!

in the example I uploaded, I just defined a vector by using two vertexes and moved the objects along its direction. It worked because they were cubes, in your case that wouldn’t work.
again, even with the NDA I wouldn’t imagine uploading those 5 diamonds would be revealing.
why don’t you upload it so people can have a go at it
ok, here is a trick:
with the cones which roughly match the diamonds, I defined the vector by the first vertex and their center of mass. It should work for your diamonds if only you find the lowest vertex at the tip.
local coordinates.gh (17.6 KB)

Hi Aris, thanks so much again for taking time to create this, I’m very pleased with your help!
I can’t manage to solve my problem using your file, but I guess youre right about sharing files, I made a Rhino file with a whole row of diamonds which need to be offset aprox. 0.2 on their individual local gumball axis.
Would love to hear if there is anything possible with this, thanks again for your time.

Love, Niels

Ring_Row_V1.3dm (582.8 KB)