Loading a Rhino Plugin for multiple users on a workstation (Plugin.CreatefromAssembly exception)

I found it surprising I couldn’t find this issue from past conversations, but then maybe I just don’t know the right keywords for it.

A university wants to load Pachyderm on multiple computers and make it available to multiple users. There are some appdata issues to resolve, but also this one, which I haven’t heard of before. Any thoughts? Here is his description of the problem:

"We have lab computers that are multi-user accessible.

When I installed the latest version of Pachyderm for Rhino7 on Windows10, the plugin initializes 100% successfully as the current user.
Then I log off, and log back on as a DIFFERENT user account.

I launch Rhino, and I receive this error:

Compatibility test succeeded in 59.81s
System.Exception: No PlugIn subclass found.

at Rhino.PlugIns.PlugIn.CreateFromAssembly(Assembly pluginAssembly, Boolean displayDebugInfo, Boolean useRhinoDotNet)

This same error occurs on many different computers that I installed Pachyderm onto, with the same error outcome.

I have tried with all different combinations of user permissions, both with Local administrators privileges, and logged in as standard user.
But the result is always the same error in Rhino7.

The only way that I found to make Pachyderm work when I log in as a new user, is to fully Uninstall Pachyderm from the Windows system, and the Reinstall Pachyderm.

However, it’s unreasonable to perform this reinstall workaround for every single user that logs onto the same computer. Especially because the student users have Standard permission access and thus cannot uninstall/reinstall software.

Would you be able to advise me on how to make Pachyderm work in a multi-user logon computer environment?"

This sounds odd. Is Pachyderm installed with an msi, rhi, yak,…?

Hi Steve,
I use Visual Studio Deployment which generates both an MSI and an EXE. Either one seems to work, but I tend to send both.

Note: this was handled offline. There is some logic in the plug-in that needed to be updated.

Thanks, Steve.