System.Exception: No PlugIn subclass found


Do you know if Rhino has a log? I’m trying to load my plugin, and in Rhino works, but using my Skin drops that error:

System.Exception: No PlugIn subclass found.
   at Rhino.PlugIns.PlugIn.CreateFromAssembly(Assembly pluginAssembly, Boolean displayDebugInfo, Boolean useRhinoDotNet)

I’m trying to figure out what can be the problem. :slight_smile:



I’m still trying to fix, and I was testing in a clean virtual machine and exactly the same! :slight_smile: If I run Rhino works, but in my skin no.

Other test I was doing is just add a Messagebox when on the OnLoadPlugin method, but the error is until Load the plugin.

The constructor of the plugin is empty, too! :slight_smile:


Fixed! It was a problem in the release configuration!!! It was Any CPU, just I changed to 64 as in debug!


I am having exactly the same problem, but I am compiling for x64. Annoyingly, it works in all the computers I have tried, except for a client’s computer.

I have checked older threads where people have had a similar issue, and they found that it was related to Windows Updates, although I do not understand why.

Is there anything else that may be causing this issue?

Edit: After some extra research, it seems this only happens with Rhino 7, regardless of whether I compile the plug-in using Rhinocommon 6 or 7.

You mean a No PlugIn subclass found exception? Can you provide any more details and/or post a sample project that isn’t working for you? Otherwise, we won’t get very far…

– Dale

Of course, sorry. I thought it was implied.

When the plug-in is loaded, and after the compatibility check, I get exactly the same error as Rafael had:

This is for a plug-in we develop and it has been working in Rhino 6 without any major problems. Although most of our customers are still on Rhino 6, new ones are of course buying Rhino 7, and when loading the plug-in they get this error.

We have tested the plug-in internally with Rhino 7 and we have not encountered any issues and we are only able to replicate the error at some of our customers’ machines. We have also tried building the plug-in using Rhinocommon 7 and the same happens.

In older threads with people having the same issue, most of the time it seems they were compiling for 32 bits, but if it is the same here, I cannot find a culprit.

Since we cannot replicate the issue in-house, I can’t offer a sample project. Furthermore, our plug-in only starts logging when loaded. I have also checked Rhino’s logs and I could not find any mention of the plug-in loading, or failing to load.

I understand that with this information there is not a lot you can do, but perhaps you can offer some potential explanation for it? Then we will have a lead to follow.

Thanks in advance!

Hi again,

We found the problem, and it is quite embarrassing actually.
We noticed that the plug-in worked in machines that had Rhino 6 installed at the time of installation of the Plug-in. After some digging, we found that in a specific part of the code we were referring to the following hard-coded path:


But of course, if only Rhino 7 is installed, then the path above doesn’t exist. An exception is thrown when the path could not be found, but for some reason is not shown anywhere.

Anyway, thanks for trying to help in the first place.