Linetypes broken

It seems that in latest V8.7 linetypes are not displayed at all. In PDF they are printed but its impossible to see them in model nor layout.

1 Like

This is what I’m seeing:
image

1 Like

in new file it works in my older one it doesnt. will send you file

1 Like

Same problem here! I can’t see any lines or text-elements in Layout Mode (I’m working with Rhino for Mac). :sleepy:
I’ll try to export it as Rhino V7 file and check it in V7 now.

Update: as I said I exported a V7-file. And in V7 all lines, measurements and title blocks are shown.
@Juan_Gallo may you can try it the same way

*I really like the flexibility of Rhino V8 User Interface but as a bunch of other people here I have sooooo many problems with V8; shut-downs without warnings, pixeled icons, deleted containers,… *

1 Like

Hi Benjamin -

I take it you can’t post your SystemInfo and a simple 3dm file that shows this behavior either?
-wim

hello, can you see linetypes in the file i sent you?

Hi Wim,

Unfortunatly yesterday I hadn’t the time to send an example file due to file preparation (personal client informations I have in the document and which I have to delete). But now – here is an example.

Problem:

  • I can’t see any lines or measurements or text elements/annotations, which I already put into the layouts before
  • If I draw a new line, it’s not shown

May good to know:

  • Saving the same file as V7 and open it in V7 solves the problem for the moment
  • some of my text elements are automaticly generated/ connected to the document information (e.g. company name etc.)
  • The only element, which is shown in the layout mode (beside the viewport) is my implemented company logo (imported picture; may it won’t show on your computer)
  • for some text elements I used the font „Galaxie Polaris“ (not all), which may will be replaced on your computer
  • yesterday I did also the latest Rhino V8 Mac update (8.6.24101.05002, 2024-04-10) but it’s still not working
    systeminformation_NoLinesInLayouts.txt (12.5 KB)
    NoLinesInLayouts.3dm (5.4 MB)

System:

→ see the .txt file attached

Bytheway almost every time when Rhino crashed I am writing a short a crash report and I send it to McNeel.

Thanks for your support!

– Ben

Hi Ben -

Just to make sure, this topic is about linetypes not showing on curves, but you are reporting that you are not seeing curves at all, correct?
On your system, was this different in a previous version of Rhino 8, and, if so, which version?
Also, does it make a difference when you run TestMetal and have that switch to the old (and no longer supported) OpenGL display engine?
FWIW, I’m not seeing any difference between Rhino 7 and Rhino 8 with your file and all geometry is visible on my M3 Mac, and I’d have to see if I can find someone with similar specs as your hardware to see if this can be reproduced.

Hi Ivan -

I got that file now and I see that this worked fine before. I’ll have to locate the breaking change and report that. FWIW, in 8.7, moving geometry to the origin will make this work as expected.
-wim

for now it is not super critical to me since it prints correctly but this is a pure regression. always test new version with geometry far from origin :smiley:

Thanks, Ivan.
There must be something else going on in addition to it being far from the origin. Your lines are only about 1 million units away from the origin; in my custom start-up template, I need to move geometry to 40 million units away before starting to see issues with only some of the linetypes.
At any rate → RH-81516 Display: No linetype segments FFO
-wim

@wim Ahh you’re so right - linetypes vs. lines & curves :face_with_peeking_eye: sorry
If it’s helpful, shall I open a new topic?

Last time I worked on that file was one month ago in Rhino 8 without any problems. I can’t tell you which R8 update I had but normally I do every update if there’s any new one. Yesterday I had to work on that file and it appeared these problems with the curves in layout mode. Then I did the newest update but I didn’t fix it.

Thanks for your advices, I’ll give it a try later today and I’ll get back later with the results

1 Like

Hey Wim, I run TestMetal and now, with openGL there is no difference. same problem – no lines, curves etc. in Layout-mode. the short video screenshot attached is with metal API on but same with openGL. Any other idea?


Hey Ben -

Thanks for that screenshot! That clarifies things…
It clearly shows that curves are visible in details on the layout.
What happens when you activate a detail and change the display mode of that detail from the current Shaded to Wireframe?
-wim

What you see there is: it only shows the curves, which are part of the detail.
But if I try to draw lines on to the layout itself (onto the “paper”) - those curves won’t show up (or they are disappearing?!)
You can see that in the demonstration when I start the curve outside the detail.

If I change detail mode to wireframe there is no difference. But I think I didn’t depend on the detail mode; it’s something with the layout…
So no chance to draw for example title blocks onto layouts or annotation etc.
And even If I copy all to a new file it don’t work

Hi Ben -

What happens when you start a new file from a factory-default template, create a layout without details, and draw a rectangle on that layout?
-wim

Same. Even in new templates there is no way to create any elements apart details in layout mode. But if I select all elements on a layer in layout mode with the drawn curves (which I can’t see, but there is a “invisible selection”; and it’s not hidden behind a detail) and I copy it to the normal viewport I can see them. If I copy/paste the element again to a layout, then they are invisible again. Finally next week I’ll try to reinstall Rhino 8 and check it again. Wim, thanks for all your help and advices!:pray:

Rando suggestion that’s miffed me before. Sort of like what @wim said earlier, but if you go into a detail and set Display Mode to wireframe. Then escape or dble click out so you are in Layout soace again. Right Mouse Button click (or hit spacebar) in Layout space to Repeat “SetDisplay to Wireframe.”

That will make sure your Layout Psace is in Wireframe display mode, and not stufk in Render or some other non-crv-displaying mode.

:man_shrugging:t2: Just a thought.

Alan

Hi Ben -

I suppose you could try that, but reinstalling is not likely to do anything.

If you are installing final Service Releases (i.e. not release candidates), this sounds like both 8.6 and 8.5 are now failing, and that, perhaps, 8.4 was working.
On macOS, you can have different versions “installed” at the same time by dragging the Rhino icon onto the desktop instead of onto the “Applications” folder, and then giving the instance on the desktop a unique name, e.g. “8.5”.
Please download and install 8.5 and 8.4 to check if any of those work as expected.

That’s along the same line as I was thinking, yes. But making a new layout in a new file will ensure that the “Wireframe” mode will be used. I was checking if that display mode had gotten modified to not show curves and annotations, but, as Ben writes, changing to “Wireframe” in a detail still shows the curves and annotations in that detail. At least, that’s how I interpreted the following:

Just to make sure, is that interpretation correct, Ben?
-wim

Yep, thats correct. The changes of the detail display mode do nothing with the display mode of my layout.

I updated Rhino today and noticed the same thing.
I hope a fix will come soon, as I need to work speacially with typelines right now… Terrible timing for this bug.

I tried to import my file into a new file, but it didn´t fix it.